Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 28/12/2008, à 18:56

kahlil

[résolu] Le PC ne s'éteint (toujours) pas

Bonjour à tous,

  Alors je réitère cette demande d'aide de résolution de ce problème qui est le dernier qui m'enquiquine avec mon installation d'ubuntu. J'ai déjà essayé ça et ça sans succès. Je souhaite donc tout reprendre posément pour essayer de vaincre.

  J'ai ce problème depuis Dapper; il est apparu un jour et il y a eu quelques courtes disparitions :
Quand je clique sur le bouton arrêt, l'ordinateur s'éteint sauf que les ventilateurs continuent de tourner...

   Donc ma config :

Un ordinateur de type Desktop sous Hardy (2.6.24-22-generic) que j'avais installé proprement à l'époque. Ma carte mère est une ASUS P5GDC-V deluxe.

   Options du BIOS actuellement :
Dans power :
Suspend Mode       : [S1 (POS) Only]
ACPI 2.0 support    : [No]
ACPI APIC Support : [Enabled]

   Mon /boot/grub/menu.lst :

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default		0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout		2

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title		Windows 95/98/NT/2000
# root		(hd0,0)
# makeactive
# chainloader	+1
#
# title		Linux
# root		(hd0,1)
# kernel	/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title		Ubuntu 8.04.1, kernel 2.6.24-22-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-22-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro quiet splash
initrd		/boot/initrd.img-2.6.24-22-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-22-generic (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-22-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro single
initrd		/boot/initrd.img-2.6.24-22-generic

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro quiet splash
initrd		/boot/initrd.img-2.6.24-21-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro single
initrd		/boot/initrd.img-2.6.24-21-generic

title		Ubuntu 8.04.1, kernel 2.6.24-19-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-19-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro quiet splash
initrd		/boot/initrd.img-2.6.24-19-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-19-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro single
initrd		/boot/initrd.img-2.6.24-19-generic

title		Ubuntu 8.04.1, kernel 2.6.24-18-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-18-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro quiet splash
initrd		/boot/initrd.img-2.6.24-18-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-18-generic (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-18-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro single
initrd		/boot/initrd.img-2.6.24-18-generic

title		Ubuntu 8.04.1, kernel 2.6.24-16-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro quiet splash
initrd		/boot/initrd.img-2.6.24-16-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-16-generic (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=bf205980-5d45-4995-bbaa-381860681ef0 ro single
initrd		/boot/initrd.img-2.6.24-16-generic

title		Ubuntu 8.04.1, memtest86+
root		(hd0,0)
kernel		/boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title		Other operating systems:
root


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
title		Ubuntu 7.10, kernel 2.6.22-14-generic (on /dev/sda3)
root		(hd0,2)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=95d20465-8df0-41bf-ac27-5a4053ca8f6e ro quiet splash 
initrd		/boot/initrd.img-2.6.22-14-generic
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
title		Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode) (on /dev/sda3)
root		(hd0,2)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=95d20465-8df0-41bf-ac27-5a4053ca8f6e ro single 
initrd		/boot/initrd.img-2.6.22-14-generic
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
title		Ubuntu 7.10, kernel 2.6.20-16-generic (on /dev/sda3)
root		(hd0,2)
kernel		/boot/vmlinuz-2.6.20-16-generic root=UUID=95d20465-8df0-41bf-ac27-5a4053ca8f6e ro quiet splash 
initrd		/boot/initrd.img-2.6.20-16-generic
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
title		Ubuntu 7.10, kernel 2.6.20-16-generic (recovery mode) (on /dev/sda3)
root		(hd0,2)
kernel		/boot/vmlinuz-2.6.20-16-generic root=UUID=95d20465-8df0-41bf-ac27-5a4053ca8f6e ro single 
initrd		/boot/initrd.img-2.6.20-16-generic
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
title		Ubuntu 7.10, memtest86+ (on /dev/sda3)
root		(hd0,2)
kernel		/boot/memtest86+.bin  
savedefault
boot

Et une remarque, je me suis lu pas mal de doc sur les options passables au kernel au demarrage mais c'est pas bien clair dans ma tête wink

   Mon /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
sbp2

Mon /etc/init.d/halt :

#! /bin/sh
### BEGIN INIT INFO
# Provides:          halt
# Required-Start:    umountroot
# Required-Stop:
# Should-Start:      lvm raid2
# Should-Stop:
# Default-Start:     0
# Default-Stop:
# Short-Description: Execute the halt command.
# Description:
### END INIT INFO

PATH=/usr/sbin:/usr/bin:/sbin:/bin
[ -f /etc/default/halt ] && . /etc/default/halt

. /lib/lsb/init-functions

do_stop () {
	if [ "$INIT_HALT" = "" ]
	then
		case "$HALT" in
		  [Pp]*)
			INIT_HALT=POWEROFF
			;;
		  [Hh]*)
			INIT_HALT=HALT
			;;
		  *)
			INIT_HALT=POWEROFF
			;;
		esac
	fi

	# See if we need to cut the power.
	if [ "$INIT_HALT" = "POWEROFF" ] && [ -x /etc/init.d/ups-monitor ]
	then
		/etc/init.d/ups-monitor poweroff
	fi

	# Don't shut down drives if we're using RAID.
	hddown="-h"
	if grep -qs '^md.*active' /proc/mdstat
	then
		hddown=""
	fi

	# If INIT_HALT=HALT don't poweroff.
	poweroff="-p"
	if [ "$INIT_HALT" = "HALT" ]
	then
		poweroff=""
	fi

	log_action_msg "Will now halt"
	sleep 1
	halt -d -f -i $poweroff $hddown
}

case "$1" in
  start)
	# No-op
	;;
  restart|reload|force-reload)
	echo "Error: argument '$1' not supported" >&2
	exit 3
	;;
  stop)
	do_stop
	;;
  *)
	echo "Usage: $0 start|stop" >&2
	exit 3
	;;
esac

:

Voilà pour l'instant, j'éditerai au fur et à mesure. Ah si une question de plus, quels journaux systèmes pourraient être utiles à la résolution de ce problème ?
                                                                               Merci !!!


PS : les conséquences de ces arrêts sauvages

Dernière modification par kahlil (Le 28/01/2009, à 13:12)

Hors ligne

#2 Le 29/12/2008, à 09:31

Rizzen Virnn

Re : [résolu] Le PC ne s'éteint (toujours) pas

Je ne sais pas ce que ça vaut mais essaye peut être ceci
http://forum.ubuntu-fr.org/viewtopic.php?id=114866


Ubuntu 12.04 32bit - Archlinux 64 bit
HP Pavilion dv6790eb
Blog

Hors ligne

#3 Le 02/01/2009, à 00:18

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

Pas bon ça,

  Les noyaux optimisés n'existent plus depuis Edgy...

         Merci quand même !

Hors ligne

#4 Le 02/01/2009, à 05:00

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

Personne pour la question concernant les journaux système ?

Hors ligne

#5 Le 02/01/2009, à 08:34

figaro

Re : [résolu] Le PC ne s'éteint (toujours) pas

Ce problème existe avec certains Bios plus ou moins anciens.

Essayes d erajouter sur la ligne de boot du menu.lst de grub les trois options suivantes en fin de ligne :

noapic nolapic acpi=force


Le blog de figaro (astuces diverses et tutos Samba pour débutants)
Le blog de cep (astuces Linux avancées)
Debian Lenny 6.0.1, Ubuntu 10.04.2, Ubuntu Remix 9.10, Ubuntu Netbook 10.04

Hors ligne

#6 Le 03/01/2009, à 15:47

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

Je vais (re-)faire le test, mais j'explore actuellement une autre piste : la mise en veille éteint bien l'ordinateur ! Je vais essayer de voir le /etc/init.d/"mise en veille" ... et de comparer avec le halt...

je vous tient au courant; je suis toujours intéressé si quelqu'un sait quels journaux système regarder pour savoir ce qui chie lors d'un arrêt wink

Hors ligne

#7 Le 04/01/2009, à 01:48

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

Oui heu ben c'est lequel qui correspond à la mise en veille ?

lol

Hors ligne

#8 Le 28/01/2009, à 12:48

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

up

@figaro : c'est pour les portables ça plutôt ! Je me trompe peut-être, en tout cas pas de changements...

Hors ligne

#9 Le 28/01/2009, à 13:01

bubu8941

Re : [résolu] Le PC ne s'éteint (toujours) pas

Question , c'est quoi qui gère ton son sur ta bécane ?

Je m'explique, si cest de l'intel tu as peut-être ce souci qui n'existe pas seulement sur les eeepc (connu de façon empirique lol ), donne le résultat d'un lspci, si tu as de l'intel tente la manip ci-dessous

doc eeepc ubuntu  a écrit :

Carte son et arrêt de l'ordinateur

Quand on éteint l'Eee PC, surprise, le voyant de mise sous tension reste allumé. En effet, la carte son ne s'arrête pas. Voici une solution :

   1.
      Éditez le ficher (avec les droits d'administration) /etc/init.d/halt
   2.
      Ajoutez à la fonction do_stop (voir exemple) : modprobe -r snd-hda-intel

Cela doit donner quelque chose comme :

[...]
do_stop () {
        modprobe -r snd-hda-intel
        if [ "$INIT_HALT" = "" ]
        then
[...]

Il se peut que malgré cela, l'ordinateur persiste à ne pas s'arrêter, la solution est de rajouter cette ligne à la fin du fichier /etc/default/halt

rmmod snd-hda-intel


Le bar est loin, la route est verglacée, l'église est proche mais je marcherai avec prudence.
Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade !

Hors ligne

#10 Le 28/01/2009, à 13:08

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

oui c'est du intel wink

je fais ça de suite !

Hors ligne

#11 Le 28/01/2009, à 13:14

kahlil

Re : [résolu] Le PC ne s'éteint (toujours) pas

Bubu8941, que la paix soit sur toi !

  Un gigantesque merci !

  Cela devait être ça, je n'ai pas eu besoin de la deuxième instruction (dans le /etc/default/halt) !!!

YOUPIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Hors ligne

#12 Le 28/01/2009, à 14:05

bubu8941

Re : [résolu] Le PC ne s'éteint (toujours) pas

Merci \o/


Le bar est loin, la route est verglacée, l'église est proche mais je marcherai avec prudence.
Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade !

Hors ligne

Haut de page ↑