Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 02/08/2013, à 16:01

tadaa9

Serveur qui risque de ne pas rebooter correctement !

Bonjour,

Je dispose d'un serveur OVH Kimsufi sous Ubuntu 12.04.2 LTS.

J'ai effectué la mise à jour du serveur ce matin en tapant les commandes : "aptitude update && aptitude upgrade". Lors de cette mise à jour, j'ai eu un écran "Configuration de grub-pc" avec pour message "Le chargeur d'amorçage Grub était précédemment installé sur un disque qui n'est plus présent ou dont l'identifiant unique a changé pour une raison ou une autre..." ! Ce même écran me proposait d'installer GRUB sur "/dev/sda1" : l'unique partition listée.

J'ai donc sélectionné la seule partition proposée mais j'ai eu une erreur m'indiquant que l'installation de GRUB sur celle-ci avait échouée et j'ai été renvoyé sur l'écran de départ. Or, n'ayant pas d'autre choix, je n'ai pu que quitter l'écran de "Configuration de grub-pc".

Pour information, voici la partie du log de mise à jour qui concerne GRUB :

Paramétrage de grub-pc (1.99-21ubuntu3.10) ...
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-setup: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-setup: error: cannot guess the root device. Specify the option `--root-device'.
Generating grub.cfg ...
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
Warning: update-grub_lib is deprecated, use grub-mkconfig_lib instead
Found linux image: /boot/bzImage-3.2.13-xxxx-grs-ipv6-64
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
/usr/sbin/grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
  No volume groups found
grub-probe: warn: disk does not exist, so falling back to partition device /dev/sda1.
umount: /var/lib/os-prober/mount: not mounted
done

Il y a un soucis ! Mais lequel ? J'ai donc continué à chercher, sur Internet, mais aussi sur le serveur.

Mes constats, la commande "sudo fdisk -l" ne retourne rien ce qui est étrange !
Un "ll /boot" me retourne :

drwxr-xr-x  3 root root    4096 sept.  6  2012 ./
drwxr-xr-x 24 root root    4096 sept.  8  2012 ../
-rw-r--r--  1 1002 1002 6134704 avril  2  2012 bzImage-3.2.13-xxxx-grs-ipv6-64
drwxr-xr-x  3 root root   12288 août   2 15:38 grub/
-rw-r--r--  1 1002 1002 2206409 avril  2  2012 System.map-3.2.13-xxxx-grs-ipv6-64

Où sont passés "initrd", "vmlinuz" et compagnie ?

Avez-vous des idées ?

Dernière modification par tadaa9 (Le 02/08/2013, à 16:02)

Hors ligne

#2 Le 02/08/2013, à 17:43

omgxulia

Re : Serveur qui risque de ne pas rebooter correctement !

Salut,

même constat pour moi. Je vais éviter de redémarrer le server sans plus d'infos...

Hors ligne

#3 Le 03/08/2013, à 10:38

tadaa9

Re : Serveur qui risque de ne pas rebooter correctement !

Salut,

Est-ce que ton serveur est hébergé chez OVH ? Il s'agit d'un Ubuntu 12.04.2 LTS ?

Pour ma part, j'ai comparé avec un autre serveur chez OVH ayant la même configuration mais dont les dernières mises à jour ne sont pas faites, et idem, je n'ai pas de vmlinuz, initrd et la commande "sudo fdisk -l" ne retourne rien. Je pense que c'est normale finalement et que c'est une fausse piste par rapport au problème de GRUB. En effet : de ce que j'ai pu lire, les distributions nues proposées par OVH sont des distributions modifiées -> le noyau notamment !

D'ailleurs, peut-être que cela pose des problèmes lors des mises à jour.

Hors ligne

#4 Le 03/08/2013, à 17:11

cavaliers23

Re : Serveur qui risque de ne pas rebooter correctement !

Idem avec mon kimsufi et Ubuntu 12.04.2 LTS !


Mémoire              : 7,7 Gio
Processeur          : Intel® Core™ i7-4770K CPU @ 3.50GHz × 8
Carte graphique  : GeForce GTX 770/PCIe/SSE2
Type d'OS           : Ubuntu 14.04 LTS (64 bits)

Hors ligne

#5 Le 04/08/2013, à 11:36

tadaa9

Re : Serveur qui risque de ne pas rebooter correctement !

Ok, nous sommes 3 ! Est-ce que de votre coté, vous avez des idées ?

Pour information : j'ai redémarré le serveur cette nuit et aucun soucis à déplorer, il est bien reparti !

Hors ligne

#6 Le 04/08/2013, à 12:19

cavaliers23

Re : Serveur qui risque de ne pas rebooter correctement !

non, pas la moindre idée, mais je me soigne 8-)


Mémoire              : 7,7 Gio
Processeur          : Intel® Core™ i7-4770K CPU @ 3.50GHz × 8
Carte graphique  : GeForce GTX 770/PCIe/SSE2
Type d'OS           : Ubuntu 14.04 LTS (64 bits)

Hors ligne

#7 Le 07/08/2013, à 00:50

omgxulia

Re : Serveur qui risque de ne pas rebooter correctement !

Pour information : j'ai redémarré le serveur cette nuit et aucun soucis à déplorer, il est bien reparti !

c'est déjà une bonne nouvelle... pas plus d'infos de mon coté et je n'ai pas osé redémarrer pour l'instant (Ubuntu 12.4 chez OVH).

Hors ligne

#8 Le 09/08/2013, à 14:26

cavaliers23

Re : Serveur qui risque de ne pas rebooter correctement !

Bonjour
C'est sans doute sans rapport, mais la mise à jour d'aujourd'hui, n'est pas non plus au top :


Les paquets suivants seront mis à jour :
  apport python-apport python-problem-report
3 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 237 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
Réception de : 1 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu/ precise-updates/main python-problem-report all 2.0.1-0ubuntu17.4 [9 342 B]
Réception de : 2 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu/ precise-updates/main python-apport all 2.0.1-0ubuntu17.4 [81,1 kB]
Réception de : 3 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu/ precise-updates/main apport all 2.0.1-0ubuntu17.4 [147 kB]
237 ko réceptionnés en 0s (1 402 ko/s)
(Lecture de la base de données... 59154 fichiers et répertoires déjà installés.)
Préparation du remplacement de python-problem-report 2.0.1-0ubuntu17.3 (en utilisant .../python-problem-report_2.0.1-0ubuntu17.4_all.deb) ...
Dépaquetage de la mise à jour de python-problem-report ...
Préparation du remplacement de python-apport 2.0.1-0ubuntu17.3 (en utilisant .../python-apport_2.0.1-0ubuntu17.4_all.deb) ...
Dépaquetage de la mise à jour de python-apport ...
Préparation du remplacement de apport 2.0.1-0ubuntu17.3 (en utilisant .../apport_2.0.1-0ubuntu17.4_all.deb) ...
stop: Job failed while stopping
invoke-rc.d: initscript apport, action "stop" failed.
Dépaquetage de la mise à jour de apport ...
Traitement des actions différées (« triggers ») pour « ureadahead »...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de python-problem-report (2.0.1-0ubuntu17.4) ...
Paramétrage de python-apport (2.0.1-0ubuntu17.4) ...
Paramétrage de apport (2.0.1-0ubuntu17.4) ...
Installation de la nouvelle version du fichier de configuration /etc/init/apport.conf ...
apport start/running


Mémoire              : 7,7 Gio
Processeur          : Intel® Core™ i7-4770K CPU @ 3.50GHz × 8
Carte graphique  : GeForce GTX 770/PCIe/SSE2
Type d'OS           : Ubuntu 14.04 LTS (64 bits)

Hors ligne

#9 Le 11/08/2013, à 10:23

tadaa9

Re : Serveur qui risque de ne pas rebooter correctement !

@cavaliers23 : Mise à jour avec la même erreur au niveau de "Apport". Cela ne me semble pas bien grave car le start est bon après mise à jour. En plus, d'après la doc (https://wiki.ubuntu.com/Apport), Apport n'est pas quelque chose de très important...

Hors ligne

#10 Le 11/08/2013, à 11:47

cavaliers23

Re : Serveur qui risque de ne pas rebooter correctement !

tadaa9 a écrit :

@cavaliers23 : Mise à jour avec la même erreur au niveau de "Apport". Cela ne me semble pas bien grave car le start est bon après mise à jour. En plus, d'après la doc (https://wiki.ubuntu.com/Apport), Apport n'est pas quelque chose de très important...

oui, oui, c'est surtout pour se sentir moins seul, face à l'ubuntu "maison" de OVH.
Amicalement !


Mémoire              : 7,7 Gio
Processeur          : Intel® Core™ i7-4770K CPU @ 3.50GHz × 8
Carte graphique  : GeForce GTX 770/PCIe/SSE2
Type d'OS           : Ubuntu 14.04 LTS (64 bits)

Hors ligne

#11 Le 14/10/2013, à 16:25

mizore

Re : Serveur qui risque de ne pas rebooter correctement !

Bonjour,

J'ai eu le même soucis sur ma mise a jours chez OVH (aussi en Ubuntu LTS 12.04)

Après avoir chercher longtemps,
J'ai résolu le problème ce matin:
Suppression de grub:

root# aptitude purge grub

(On demande confirmation pour la suppressions des fichiers, tappez: y)

Réinstall de grub:

root# aptitude install grub
root# reboot

Si cela peux servir.

Hors ligne

#12 Le 14/10/2013, à 21:11

cavaliers23

Re : Serveur qui risque de ne pas rebooter correctement !

Bonjour
Merci à mizore pour ses conseils que j'ai suivis.
Et le reboot a eu lieu.
A bientôt, peut-être ? 8-)
Amicalement.
==


Mémoire              : 7,7 Gio
Processeur          : Intel® Core™ i7-4770K CPU @ 3.50GHz × 8
Carte graphique  : GeForce GTX 770/PCIe/SSE2
Type d'OS           : Ubuntu 14.04 LTS (64 bits)

Hors ligne