Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 17/06/2009, à 14:22

skurty

[RESOLU] Ralentissement avec les pilotes ATI

Bonjour,

j'ai Ubuntu 9.04 (64 bits) sur mon Dell Studio 15 et j'ai installé les pilotes propriétaires pour ma carte graphique et cela provoque des ralentissements.
Lorsque je veux agrandir une fenêtre qui est minimisé, elle mets 1 ou 2 secondes, même si je ne lance rien d'autre. Si je clique sur l'icône pour afficher le bureau et que tous les fenêtres sont réduites, cela met beaucoup de temps avant de réagir et d'afficher toutes les fenêtres (4 sec avec nautilus, la console et firefox).

Avec la commande glxinfo | grep "OpenGL", j'obtiens :

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3400 Series
OpenGL version string: 2.1.8575
OpenGL shading language version string: 1.20
OpenGL extensions:

Voici la config :
processeur : Intel Core 2 Duo P8600
ram : 4Go
carte graphique : ATI Radeon Mobility HD 3450 256 Mo
ecran : 15,4 pouces

Y a-t-il un moyen de ne plus avoir ces ralentissements en gardant les pilotes activés svp ?

Merci d'avance

Dernière modification par skurty (Le 25/06/2009, à 21:39)

Hors ligne

#2 Le 17/06/2009, à 14:25

sergei_ruskof

Re : [RESOLU] Ralentissement avec les pilotes ATI

bonjour,
si tu as les effets visuels d'activés enleve les,et peut etre que sa resoudra ton probleme.

Hors ligne

#3 Le 17/06/2009, à 14:56

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

Salut,

Une nouvelle version des catalysts est sortie la 9.6. Il semblerait que ce problème soit corrigé. A moins que je ne me trompe mais bon tu peux toujours essayer. wink

Hors ligne

#4 Le 17/06/2009, à 15:10

skurty

Re : [RESOLU] Ralentissement avec les pilotes ATI

En désactivant les effets visuels il n'y a plus de ralentissement.

Pour les derniers pilotes ATI, seront-ils bientôt dans les dépôts officiels ou faut-il les installer manuellement ?

Hors ligne

#5 Le 17/06/2009, à 15:30

Ereos

Re : [RESOLU] Ralentissement avec les pilotes ATI

Il faut les installer manuellement mais c'est d'une simplicité que tu continueras à l'utiliser big_smile.

Tu désinstalles correctement les drivers que tu as installé. Dans Synaptic, tu vérifies bien qu'aucun paquet fglrx n'est installé.

Tu télécharges le driver 9.6 sur le site d'ati.

Clique-droit le drivers .run puis dans Propriétés -> Permission, tu coches la case pour l'executer en tant que programme.

Ensuite, tu ouvres une console, tu tapes cd Bureau (si le driver est sur le Bureau)

Et la commande suivante :
Sudo ./a (appuie sur Tab pour afficher le nom complet)

Un petit entrée et tu te laisse guidé.
Quand l'install est finie, un petit aticonfig --initial -f puis tu redémarres le PC.
Si c'est écran noir, installation foireuse. Mais si au démarrage, t'as compiz d'activé, c'est que ça a fonctionné.


Ubuntu.... Et dire qu'il y a des personnes qui aiment cette chose...

Hors ligne

#6 Le 17/06/2009, à 15:32

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

Il faut les installer manuellement. Ils sont là:
http://support.amd.com/us/gpudownload/l … ng=English

C'est simple à installer:
1- un clic droit sur le pilote puis propriété. Dans l'onglet permission cocher la case qui permet l'exécution
2-tu ouvres un terminal puis tu tapes sudo, tu fais glisser-déposer du fichier du drivers dans le terminal puis entrée
3- mot de passe puis suivant, suivant....etc.
4-a la fin toujours dans le terminal tu tapes:  sudo aticonfig --initial -f
5-redemarrage

J'arrive après la bataille. Enfin bref c'est pareil que ce que t'a dit Ereos mais en différent big_smile

Dernière modification par pipocas (Le 17/06/2009, à 15:36)

Hors ligne

#7 Le 17/06/2009, à 16:12

skurty

Re : [RESOLU] Ralentissement avec les pilotes ATI

Merci de m'avoir bien détaillé l'installation, dans Synaptic il restait juste un paquet fglrx-m... que j'ai désinstallé.

L'installation du driver s'est bien passé mais ça n'a rien changé, j'ai toujours ces ralentissements avec les effets visuels activés (normaux) hmm

Voici ce que j'ai maintenant :

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3400 Series
OpenGL version string: 2.1.8673
OpenGL shading language version string: 1.30
OpenGL extensions:

Hors ligne

#8 Le 17/06/2009, à 16:26

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'ai retrouvé le topic qui en parle:
http://forum.ubuntu-fr.org/viewtopic.php?id=325654

Il semble qu'il y est eu un fix. Je pensais qu'il était inclut sur le nouveau drivers mais apparemment non. A voir...

Hors ligne

#9 Le 17/06/2009, à 17:11

skurty

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'ai suivi le lien qui était dans le topic. J'ai ensuite suivi le 2 ème lien en ajoutant les 2 dépots et la signature. J'ai regardé les maj qu'il me proposait et en redémarrant il y a eu un problème, il a juste démarré en basse résolution.

J'ai donc suivi ce qu'il y avait dans la doc pour le ati.run pour la désinstallation :

Désinstallation des pilotes

Si les performances de ce nouveau pilote ne vous conviennent pas, vous pouvez le désinstaller proprement et récupérer l'accélération 3D avec le pilote libre radeon.
Pour cela, il suffit de taper quelques commandes :
Tout d'abord on désinstalle tous les paquets deb fglrx installés :

sudo mv /etc/xdg/compiz/compiz-manager.ubuntu /etc/xdg/compiz/compiz-manager

puis désinstallez fglrx*

Ensuite on utilise le script de désinstallation des pilotes ati pour tout remettre comme avant l'installation de ces derniers :

sudo sh /usr/share/ati/fglrx-uninstall.sh #si vous avez des pilotes = ou > à la version 8.42.3

sudo sh /usr/share/fglrx/fglrx-uninstall.sh #si vous avez des pilotes un peu plus anciens.

Puis suivez ce qui vous concerne :
Si l'on passe au pilote propriétaire des dépôts

Tapez ensuite les commandes :

sudo apt-get install xorg-driver-fglrx   

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Et en redémarrant, j'ai activé les effets visuels normaux et je n'ai plus de ralentissements...

Je ne sais pas d'où ça vient mais bon ça fonctionne ^^

Par contre quand j'utilise VLC, Ubuntu plante avec un écran noir et quelques lignes qui s'effacent direct...

Dernière modification par skurty (Le 17/06/2009, à 17:29)

Hors ligne

#10 Le 17/06/2009, à 18:24

skurty

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'ai finalement réinstallé les drivers 9.6 et activé les effets et il n'y a plus de ralentissements alors que j'ai fait la même chose que tout à l'heure lol

Je verrais bien s'il y a des problèmes à l'utilisation ^^

Merci de votre aide wink

Hors ligne

#11 Le 17/06/2009, à 18:30

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

T'as quand même du faire un truc parce que je suis avec les 9.6 et j'ai comme un lag  d'une seconde à l'agrandissement des fenêtres. hmm (seulement avec compiz)

Dernière modification par pipocas (Le 17/06/2009, à 18:30)

Hors ligne

#12 Le 17/06/2009, à 18:54

skurty

Re : [RESOLU] Ralentissement avec les pilotes ATI

je pense que c'est en faisant ces commandes :

sudo apt-get install xorg-driver-fglrx   

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Enfin bon je ne suis pas un grand connaisseur ^^

Hors ligne

#13 Le 18/06/2009, à 00:15

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'ai resolu le problème: je n'ai plus de lags non plus.
Je n'ai pas fait les commandes que tu as dit.
En fait je crois que le patch doit être appliquer avant l'installation des drivers proprios.
Je précise que j'ai une hd4850 et que Jaunty ne propose pas les effets graphique sans drivers pour cette carte.


Edit: si vous êtes sous Ubuntu 9.10 Karmic et que vous lisez ces lignes, suivez ce post: http://forum.ubuntu-fr.org/viewtopic.ph … 1#p3009691

Edit: si vous êtes sous Ubuntu 10.04 Lucid Lynx et que vous lisez ces lignes, suivez ce post:http://forum.ubuntu-fr.org/viewtopic.ph … 6#p3438306

Conclusion:
1-Si les drivers proprios sont installés il faut les désintaller avec dans le terminal les commandes suivantes:

cd /usr/share/ati
sudo sh ./fglrx-uninstall.sh

Puis mettre à jour.

2-Ensuite  installer le patch avec dans le terminal les commandes suivantes:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
sudo su -c 'echo deb http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main  >> /etc/apt/sources.list' 
sudo su -c 'echo deb-src http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main >> /etc/apt/sources.list'

Puis mettre à jour.

3-Réinstaller les drivers proprios (cf la documentation).

Voilà en faisant cette procédure j'ai mis fin aux lags qui rendaient l'interface un peu lente avec compiz.
Ca mériterait peut êtrre une wikification ça non? tongue

Dernière modification par pipocas (Le 30/04/2010, à 21:36)

Hors ligne

#14 Le 18/06/2009, à 01:06

Django84

Re : [RESOLU] Ralentissement avec les pilotes ATI

Je confirme que le patch résout ces problèmes de latence à la minimisation-restauration des fenêtres, y compris dans Kubuntu.
Cependant pour éviter un crash du serveur X il faut désinstaller préalablement les pilotes propriétaires déjà installés.
Puis, après la mise à jour du serveur X, l'installation de "Catalyst" se fait comme indiqué dans la doc ATI.
Et... plus de latences...
Bon, il me reste maintenant qu'à installer les nouveaux Catalyst 9.6 qui viennent de sortir.

Dernière modification par Django84 (Le 18/06/2009, à 01:14)


GA-EP45-UD3R ; Intel Core 2 Duo E8500 ; ATI Radeon HD4350
  Kubuntu 14.04 64 bits.    KDE 4.13.x    pilote libre

Hors ligne

#15 Le 18/06/2009, à 14:14

sergei_ruskof

Re : [RESOLU] Ralentissement avec les pilotes ATI

je confirme aussi sa marche du tonnerre,sa m'apprendra de plus dire aux gens de desactiver les effets visuels.

Hors ligne

#16 Le 18/06/2009, à 15:32

serrum

Re : [RESOLU] Ralentissement avec les pilotes ATI

Moi, je bloque à la première étape;

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
[sudo] password for serrum: 
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
gpg: requête de la clé AF1CDFA9 du serveur hkp keyserver.ubuntu.com
gpg: le délai d'attente du serveur de clés a expiré
gpg: la réception depuis le serveur de clés a échoué: erreur du serveur de clés

C'est bon merci à vous.
Ça a parfaitement fonctionné c'est agréable de pouvoir changer de fenêtre rapidement et de ne plus avoir de coupure de la musique.

Dernière modification par serrum (Le 18/06/2009, à 15:57)


Ubuntu 11.04
Dell Studio XPS 1640

Hors ligne

#17 Le 21/06/2009, à 16:34

ehmicky

Re : [RESOLU] Ralentissement avec les pilotes ATI

Salut à tous,

Je confirme que la méthode fonctionne. Petit récapitulatif (qui reprend ce qui a déjà été dit) :

1) Désinstaller le driver propriétaire d'ATI, nommé fglrx. Pour cela faire :

cd /usr/share/ati
sudo sh ./fglrx-uninstall.sh

Si fglrx-uninstall.sh ne se trouve pas dans /usr/share/ati, aller dans dans le gestionnaire de paquets Synaptic et supprimer les paquets fglrx-kernel-source, xorg-driver-fglrx, fglrx-amdcccle et fglrx-modaliases. Il est possible aussi de les supprimer en ligne de commande à l'aide de la commande sudo apt-get remove.

2) Installer les patchs corrigeant le freeze, pour ce faire, taper dans un terminal :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
sudo su -c 'echo deb http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main  >> /etc/apt/sources.list' 
sudo su -c 'echo deb-src http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main >> /etc/apt/sources.list'

Puis mettre à jour les paquets, en ligne de commande ou, à l'aide du gestionnaire de paquets Synaptic, en faisant Recharger, puis Mettre à jour, puis Appliquer.

3) Réinstaller le driver ATI. La version actuelle est la 9.6 et peut être télécharger ici. Son nom est ati-driver-installer-9-6-x86.x86_64.run. Pour l'installer, cliquer droit sur le driver>Propriétés>Onglet Permissions, et cocher "Autoriser l'exécution du fichier comme un programme". Ouvrir ensuite un terminal, aller dans le répertoire où le driver a été téléchargé, puis faire :

sudo ./ati-driver-installer-9-6-x86.x86_64.run --buildandinstallpkg

Si un problème de dépendance survient, installer le paquet manquant (pour ma part, j'ai dû installer lib32gcc1), désinstaller et relancer l'installation.
Configurer xorg.conf en faisant :

sudo aticonfig --initial -f
sudo nano /etc/X11/xorg.conf

Rajouter à la fin du fichier :

Section "Extensions"
	Option	    "Composite" "1"
EndSection

4) Tester en tapant :

fgl_glxgears

Il ne devrait pas y avoir de bug et vos fenêtres ne devraient plus présenter de freezes.

Dernière modification par ehmicky (Le 28/06/2009, à 13:50)


Stego++, bibliothèque libre de stéganographie (avec cryptographie), à venir !
Besoin de votre aide :
Stats sur les compilateurs C++ les plus utilisés
Comment utiliser les archetypes C++ ?

Hors ligne

#18 Le 22/06/2009, à 00:37

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

Très bonne synthèse! Wikification demadée! big_smile

edit: je viens de (re)faire cette procédure. Je précise qu'il faut redémarrer juste avant l'étape 4.
A part ça tout beigne. tongue

Dernière modification par pipocas (Le 22/06/2009, à 01:10)

Hors ligne

#19 Le 22/06/2009, à 13:44

AozRoon

Re : [RESOLU] Ralentissement avec les pilotes ATI

La ligne suivant est-elle réellement nécessaire dans le "source.list" ?

sudo su -c 'echo deb-src http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main >> /etc/apt/sources.list'

Ca doit passer sans les sources, non ?

Hors ligne

#20 Le 25/06/2009, à 21:39

skurty

Re : [RESOLU] Ralentissement avec les pilotes ATI

Merci ehmicky pour ce tuto, mon problème est résolu !

Hors ligne

#21 Le 25/06/2009, à 22:22

lolo92

Re : [RESOLU] Ralentissement avec les pilotes ATI

Idem !
Un grand merci pour ce tuto !
Ma 8.10 ramait depuis 6 mois !
Bon ok, c'est pas la fluidité made in Apple mais c'est largement acceptable !
Je peux enfin faire tourner mon Cube smile
Wouhaou !!!!!

Dernière modification par lolo92 (Le 25/06/2009, à 22:26)


Toulousaing'
Sony VGN-NS12M 2Ghz RAM:3Go HD:250Go ATI HD3450
Dual-boot: VISTA + 10.04 + Virtualbox (Win7)

Hors ligne

#22 Le 05/08/2009, à 20:59

Zakapatul

Re : [RESOLU] Ralentissement avec les pilotes ATI

Merci tout le monde,

ça faisait râler de voir mon Core2Duo et son Ati HD2600 tourner moins bien que l'Athlon XP + Geforce 5200 du "grenier" xD

Voilà donc qui est réparé


2 règles du succès :
1)Ne jamais communiquer tout son savoir

Mon blog : blog.alexandredubois.com

Hors ligne

#23 Le 16/09/2009, à 17:16

Coltrane

Re : [RESOLU] Ralentissement avec les pilotes ATI

bonjour,

moi aussi j'ai essayé le changement de xserver sans le backfill.

la première fois j'ai pas rebooté entre l'installation des nouveaux paquets xserver et la réinstallation des pilotes ATI ce qui m'a valu un ecran noir au redémarrage donc je conseille de redémarrer entre chaque étape.

Sinon j'ai été super déçu par ce patch au bout du compte : je possède une config dual screen, et il est impossible de regarder une vidéo par exemple, tout en faisant autre chose sinon ça rame et ça lag.

Pareil ça rame si on déplace une fenêtre video avec le "wobbling window".
Au final on perd bien trop de fluidité pour que ce soit acceptable, j'ai donc du retourner sur metacity et désactiver les effets compiz.
C'est d'autant plus frustrant que j'avais auparavant une NVIDIA geforce 7600GT et ca marchait top nickel.
J'ai upgradé mon PC avec une ATI HD 3850 (presque deux fois plus puissante...) et ca marche 10 fois moins bien....

Espérons que les fameux drivers radeonHD (libres) progressent rapidement...


..:: SMPlayer pour les videos, Quodlibet pour l'audio ::..

Hors ligne

#24 Le 04/10/2009, à 22:05

bargeot5999

Re : [RESOLU] Ralentissement avec les pilotes ATI

ehmicky a écrit :

Salut à tous,

Je confirme que la méthode fonctionne. Petit récapitulatif (qui reprend ce qui a déjà été dit) :

1) Désinstaller le driver propriétaire d'ATI, nommé fglrx. Pour cela faire :

cd /usr/share/ati
sudo sh ./fglrx-uninstall.sh

Si fglrx-uninstall.sh ne se trouve pas dans /usr/share/ati, aller dans dans le gestionnaire de paquets Synaptic et supprimer les paquets fglrx-kernel-source, xorg-driver-fglrx, fglrx-amdcccle et fglrx-modaliases. Il est possible aussi de les supprimer en ligne de commande à l'aide de la commande sudo apt-get remove.

2) Installer les patchs corrigeant le freeze, pour ce faire, taper dans un terminal :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
sudo su -c 'echo deb http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main  >> /etc/apt/sources.list' 
sudo su -c 'echo deb-src http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main >> /etc/apt/sources.list'

Puis mettre à jour les paquets, en ligne de commande ou, à l'aide du gestionnaire de paquets Synaptic, en faisant Recharger, puis Mettre à jour, puis Appliquer.

3) Réinstaller le driver ATI. La version actuelle est la 9.6 et peut être télécharger ici. Son nom est ati-driver-installer-9-6-x86.x86_64.run. Pour l'installer, cliquer droit sur le driver>Propriétés>Onglet Permissions, et cocher "Autoriser l'exécution du fichier comme un programme". Ouvrir ensuite un terminal, aller dans le répertoire où le driver a été téléchargé, puis faire :

sudo ./ati-driver-installer-9-6-x86.x86_64.run --buildandinstallpkg

Si un problème de dépendance survient, installer le paquet manquant (pour ma part, j'ai dû installer lib32gcc1), désinstaller et relancer l'installation.
Configurer xorg.conf en faisant :

sudo aticonfig --initial -f
sudo nano /etc/X11/xorg.conf

Rajouter à la fin du fichier :

Section "Extensions"
	Option	    "Composite" "1"
EndSection

4) Tester en tapant :

fgl_glxgears

Il ne devrait pas y avoir de bug et vos fenêtres ne devraient plus présenter de freezes.

Bonsoir,

Savez-vous si avec Karmic, il faudra employer cette méthode ? (rajouter les dépôts..) ou tout marchera directement..autrement dit avez-vous déjà effectuer des tests sur Karmic ?

Merci à tous wink

Hors ligne

#25 Le 04/10/2009, à 22:50

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'ai testé sous Karmic et il y avait les ralentissements des fenêtres. Je ne suis pas allé plus loin. Je n'ai pas testé le patch. hmm

Hors ligne

Haut de page ↑