Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#51 Le 05/01/2007, à 08:29

Goalgauth

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Cathou a écrit :

Apparemment, la mésaventure de benich s'est produite également pour Goalgauth. Puisqu'il doit installer ubuntu pour un(e) novice, je lui conseille d'installer edgy et d'utiliser la solution Valente ou la solution PierreR

Merci pour tes conseils Cathou, j'avais laissé en suspens cette installation ce d'autant qu'avec Edgy j'avais un problème d'affichage ("out of range") qui finalement ne parrait pas si difficile que ça à résoudre. J'essaierai de résoudre tout ça la prochaine fois que je retourne sur ce PC...

Cathou a écrit :

La solution: désinstaller le méta-paquet linux-image-386

Mais avec la méthode de Valent ou de PierreR, aurai-je besoin de désinstaller aussi le linux-image-386 (ou plutôt le linux-image 2.6.17-10-386 comme celui qui est installé chez moi sous edgy) pour éviter devoir réinstaller à chaque mise à jour, ou alors c'est seulement pour ta méthode que tu donnes ce conseil?
Merci.

Dernière modification par Goalgauth (Le 05/01/2007, à 09:03)

Hors ligne

#52 Le 05/01/2007, à 13:03

Mazzhe

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour !

   Un grand merci pour ces paquets que vous avez fait, et merci aussi poru ce fil de discussion, très riche en informations... Voici mon expérience :

   Sur un amd64, j'ai essayé la méthode de Valente... Et j'ai eu les mêmes problèmes que Lukubuntu et freddybidouille... pas moyen d'arriver au bout de l'installation. J'ai donc vu dans le fil de discussion que cette architecture posait quelques difficultés.
   J'ai essayé de faire comme Lukubuntu (ici): installation par une autre méthode (échec au même endroit que lui) puis retour sur la méthode de Valente, mais là ça ne marchait pas... Je pense que j'avais essayé trop de choses, et que mon install n'était plus vraiment "fraiche".:(

   Le CD live amd64 ne résolvant pas mes problèmes, j'ai pris un autre chemin, trouvé grâce à cette remarque :

Cathou a écrit :

Pour info: ce n'est pas parce que tu as un Athlon64 que tu es obligé d'installer ubuntu en architecture amd64. En espérant que tu saches déja cela, ainsi que ce que ça implique..

Ah bon ? Alors une petite recherche et je tombe sur http://forum.ubuntu-fr.org/viewtopic.php?id=23632

Alors zou, on y va, on recommence tout, ce sera plus simple :
Je réinstalle complêtement le système à base d'un cd i386. Tout de suite après, j'essaye la méthode de Valente... et me revoici ici, via ce soi-disant modem ! Ouf !


Merci vous tous ! (ceux qui fait les paquets et ceux qui ont témoigné de leurs difficultés !)

Conclusion : méthode proposée pour amd64 peut-être à revoir ?
sinon : OK pour une install
  - sur processeur athlon AMD64 mais avec Ubuntu Edgy Eft pour i386
  - FAI neuf télécom dégroupage partiel
  - modem f@st 800 WA

Hors ligne

#53 Le 05/01/2007, à 20:43

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Goalgauth a écrit :

j'avais laissé en suspens cette installation ce d'autant qu'avec Edgy j'avais un problème d'affichage ("out of range") qui finalement ne parrait pas si difficile que ça à résoudre

Tu devrais pouvoir t'en sortir facilement en lançant l'install en 'safe graphics' ou bien en choisissant un mode vidéo particulier au moyen de la touche F4.

Goalgauth a écrit :

Mais avec la méthode de Valent ou de PierreR, aurai-je besoin de désinstaller aussi le linux-image-386 (ou plutôt le linux-image 2.6.17-10-386 comme celui qui est installé chez moi sous edgy) pour éviter devoir réinstaller à chaque mise à jour, ou alors c'est seulement pour ta méthode que tu donnes ce conseil?

Non, si tu utilises la méthode de Valente sous edgy tu n'as pas 'besoin' de te soucier des méta-paquets. C'est en ce sens que nous avons annoncé:
méthode Cathou => dépendante du noyau
méthode Valente => indépendante du noyau
Quant à la méthode PierreR, je ne peux pas la tester pour le moment et donc impossible de t'en dire plus..

Ceci dit ces tracas liés aux méta-paquets, décris pour dapper, sont absolument généraux et concernent tous les gens qui ont des pilotes en dehors du kernel tree. Je sais que ceci est déroutant pour les novices.. je vais prendre un dernier exemple, en espérant être tout à fait claire:
- mettons que tu sois sous edgy et que tu possèdes une webcam qui a besoin d'un pilote
- tu compiles le pilote => ta webcam marche pour le noyau en cours
- mise à jour automatique via le notificateur d'update => nouveau noyau => ta webcam ne marche plus
Ceci est un comportement tout à fait normal mais qu'il faut avoir à l'esprit, d'après moi.

Pour info, sous edgy les méta-paquets se nomment linux-image-386 ou linux-image-generic dans le cas de l'architecture i386. Une visite de Synaptic ou Adept permet de visualiser celui qui est installé par défaut.

Pour plus d'info sur les méta-paquets il existe ce vieux thread qui traite du cas sous dapper.

Pour mémoire, et pour se convaincre que les packageurs de chez ubuntu ont déc*nné vis à vis du Fast800 on peut lire ce post sur linuxfr.

Mazzhe a écrit :

méthode proposée pour amd64 peut-être à revoir ?

Déja, merci pour ton retour smile

Si tu as encore ton LiveCD edgy amd64 à portée de main, peux-tu refaire l'expérience et communiquer ce qu'affiche le programme ueaglediag?

#54 Le 05/01/2007, à 22:28

Mazzhe

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Cathou a écrit :

Déja, merci pour ton retour smile

De rien... c'est grace au retour des autres que j'ai réussi, alors ça me semblait la moindre des choses...

Cathou a écrit :

Si tu as encore ton LiveCD edgy amd64 à portée de main, peux-tu refaire l'expérience et communiquer ce qu'affiche le programme ueaglediag?

on va essayer rapidement... :

Diagnostic () driver ueagle-atm 20070105200735
# System Information
Linux version 2.6.17-10-generic (root@crested) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Fri Oct 13 15:34:39 UTC 2006 (Ubuntu 2.6.17-10.33-generic)
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
pppoatm                 8320  1 
ppp_generic            36384  9 ppp_deflate,bsd_comp,pppoatm,pppoe,pppox
eagle_usb             140196  0 
ueagle_atm             33476  0 
usbatm                 23808  2 ueagle_atm
usb_storage            89792  1 
libusual               21544  1 usb_storage
usbcore               167840  8 eagle_usb,ueagle_atm,usbatm,usb_storage,libusual,ehci_hcd,uhci_hcd
scsi_mod              181424  4 sg,sd_mod,usb_storage,libata
ADSL-USB Modem (usb-0000:00:10.0-1)
MAC: 00:60:4c:0d:ca:e9
AAL5: tx 21 ( 0 err ), rx 22 ( 0 err, 0 drop )
Line up
eth0      Link encap:Ethernet  HWaddr 00:16:17:92:5C:05  
          inet addr:192.168.xxx.xxx  Bcast:192.168.1.255  Mask:255.255.255.0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:320657 errors:0 dropped:0 overruns:0 frame:0
          TX packets:314654 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:207033587 (197.4 MiB)  TX bytes:23891288 (22.7 MiB)
          Interrupt:185 Base address:0xec00 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:166 errors:0 dropped:0 overruns:0 frame:0
          TX packets:166 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:12396 (12.1 KiB)  TX bytes:12396 (12.1 KiB)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:xxx.xxx.xxx.xxx  P-t-P:xxx.xxx.xxx.xxx  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:108 (108.0 b)  TX bytes:97 (97.0 b)

sit0      Link encap:IPv6-in-IPv4  
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
xxx.xxx.xxx.xxx 0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
# ping IP ?              [ KO ]
# test DNS resolution ?  [ KO ]
##Complete diagnostic has been saved on /home/ubuntu/.ueagle-atm/ueaglediag_20070105200735.txt
##Please keep only relevant data and remove personal informations.

Petite précision : chez moi, j'ai un routeur qui me permet de me connecter, ce qui explique eth0... mais l'ordi n'est pas pour chez moi, c'est pour ça que j'installe le modem usb. Lorsque j'arrive à la fin de la méthode de Valente (après avoir édité chap-secrets), je fais ça :

- deconnexion du cable téléphonique de mon routeur, que je branche dans le modem
- Menu Système > Administration > Réseau > désactive eth0 (mais pourquoi il apparaît toujours dans la réponse du script ?)
- puis je continue :

Brancher le cable USB de vote modem Sagem f@st. Attendre l'initialisation complète du modem : les deux voyants sont allumés

- sh /usr/bin/ueaglediag
- je débranche le cable et je le remets sur le routeur ; je réactive mon interface eth0...
et je peux vous répondre...

je ne sais pas si ça joue sur quelque chose, mais c'était pour expliquer la présence de eth0.

Voilà... J'espère que ces indications pourront vous aider wink

Hors ligne

#55 Le 05/01/2007, à 23:53

valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

Mazzhe a écrit :

Voilà... J'espère que ces indications pourront vous aider wink

Bingo ! j'ai trouvé l'erreur(*) : usbcore               167840  8 eagle_usb,ueagle_atm.....

Le module "eagle_usb" ne devrait pas être présent !
Je vais vérifier de mon coté ce paquet et j'espère te donner une réponse.... le plus rapide pour toi étant d'utiliser le paquet Cathou ou celui de PierreR

A titre "perso" j'ai essaye les trois paquets avec la version Kubuntu Edgy live CD. Les trois méthodes fonctionnent. Ses trois méthodes sont beaucoup plus simple que le "tuto" de la documentation smile Le Sagem F@st 800 est facile (maintenant) a utiliser et configurer... la méthode Valente étant la plus pénible smile
TUTO : Si quelqu'un est volontaire.... levé votre clavier! L'occasion aussi de critiquer ce qui peut l'être.

@+

* L'importance d'un retour d'information c'est vraiment pratique smile

#56 Le 07/01/2007, à 11:21

kelk'1

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour
j'ai un modem type E2T et je suis sous Edgy (installation toute fraiche)
j'ai essayé la methode de valente mais le probleme c'est qu'aucun des FAI qu'il propose n'a la même configuration que le mien :
voila la configuration de mon FAI (Planet Tunisie/Wanadoo) :

 TU01 	 Planet.tn 	 Tunisia 	0	35 (23) 	 5 - RFC2364 PPPoA LLC 	 pppoe

J'ai téléchargé les paquets, je les ai installés, j'ai modifié les fichiers chap-secrets et dsl-provider par contre sur le site de valente il est indiqué (quand on choisit le FAI DZ01 - qui a la config la plus proche de mon FAI) qu'il faut modifier le fichier /etc/init.d/adsl a la fin alors qu'il ma semblé que c'est /etc/ppp/pppoe_on_boot qu'il faut modifier pour ajouter ces lignes :

#!/bin/sh
PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin
export PATH
br2684ctl -c 0 -b -a VPI.VCI 
ifup nas0
#modprobe -q pppoe

exec pppd call dsl-provider

bon apres toutes ces modifications et un reboot mon modem est synchronisé mais pas de connexion
j'essaie alors de lancer la connexion avec le fichier adsl mais ca marche pas ! voila ce que j'ai eu :

tokou@Albert:~$ sudo /etc/init.d/adsl start
Password:
 * Demarrage interface ADSL...                                                  
br2684ctl[4850]: Interface "nas0" could not be created, reason: File exists
br2684ctl[4850]: Communicating over ATM 0.0.35, encapsulation: LLC
br2684ctl[4850]: Fatal: failed to connect on socket
Ignoring unknown interface nas0=nas0.
Plugin rp-pppoe.so loaded.
                                                                         [ ok ]
tokou@Albert:~$ ueaglediag
Diagnostic () driver ueagle-atm 20070107095055
# System Information
Linux version 2.6.17-10-generic (root@vernadsky) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Fri Oct 13 18:45:35 UTC 2006 (Ubuntu 2.6.17-10.33-generic)
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
usb_storage            75072  1 
scsi_mod              144648  3 sg,sd_mod,usb_storage
snd_usb_audio          80416  1 
snd_usb_lib            18816  1 snd_usb_audio
libusual               17040  1 usb_storage
ueagle_atm             27816  0 
usbatm                 20864  2 ueagle_atm
snd_rawmidi            27264  1 snd_usb_lib
snd_hwdep              10756  1 snd_usb_audio
usbhid                 45152  0 
snd_pcm                84612  4 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_pcm_oss
snd                    58372  12 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_rawmidi,snd_seq_device,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
usbcore               134912  10 usb_storage,snd_usb_audio,snd_usb_lib,libusual,ueagle_atm,usbatm,usbhid,ehci_hcd,uhci_hcd
ADSL-USB Modem (usb-0000:00:1d.2-1)
MAC: 00:60:4c:47:49:5a
AAL5: tx 0 ( 0 err ), rx 0 ( 0 err, 0 drop )
Line up
tokou     4906  0.0  0.1   2848   768 pts/0    R+   09:50   0:00 grep atmarp
eth0      Lien encap:Ethernet  HWaddr 00:0C:76:BF:BC:CA  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)
          Interruption:201 Adresse de base:0xcf00 

lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:146 erreurs:0 :0 overruns:0 frame:0
          TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:11012 (10.7 KiB) Octets transmis:11012 (10.7 KiB)

nas0      Lien encap:Ethernet  HWaddr 00:60:4C:47:49:5A  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

sit0      Lien encap:IPv6-dans-IPv4  
          NOARP  MTU:1480  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
# ping IP ?              [ KO ]
# test DNS resolution ?  [ KO ]
##Complete diagnostic has been saved on /home/tokou/.ueagle-atm/ueaglediag_20070107095055.txt
##Please keep only relevant data and remove personal informations.
tokou@Albert:~$

Merci d'avance

Hors ligne

#57 Le 07/01/2007, à 13:07

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Si tu regardes les infos de la clé TU01 tu verras qu'il y a une contradiction:

5 - RFC2364 PPPoA LLC      pppoe

Compte tenu de cette ambigüité, es-tu sûr et certain que Planet Tunisie exige une connexion en PPPoE?

Ceci n'est pas indiqué sur leur site web, ou alors c'est bien caché roll
Mais de toute façon il y a une adresse email d'assistance technique: peut-être qu'en leur demandant gentiment.. smile

Si effectivement tu dois te connecter en PPPoA, tu auras une autre difficulté. Dans le fichier dsl-provider, tu devras remplacer la ligne:

plugin pppoatm.so 0.35

par celle-ci:

plugin pppoatm.so 0.35 llc-encaps

..afin que l'encapsulation soit LLC au lieu de VCmux.

#58 Le 08/01/2007, à 23:19

Bouillard

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,
Je suis nouveau dans la communauté UBUNTU et j'essaye d'installer mon modem FAST SAGEM 800.
J'ai utilisé la méthode CATHOU. je suis chez ORANGE et j'ai une version v6.06.1 DAPPER?
Le modem est fonctionnel d'après modem-diagnostic, par contre, le connexion-diagnostic me remonte ppO: KO; ping: KO et résolution de noms: KO
Pourriez-vous m'aider?
Merci d'avance!

#59 Le 09/01/2007, à 00:59

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Quel est le modèle de ton Fast800?
(c'est marqué sur l'étiquette qui se trouve dessous)

Il t'a fallu installer les paquets:

   . ueagle-atm-firmwares.deb
   . ueagle-atm-2.6.15-26-386.deb, ou ueagle-atm-2.6.15-26-686.deb, ou ueagle-atm-2.6.15-26-k7.deb
   . ueagle-pppoa.deb

As-tu ensuite effectué connexion-config?

Avant d'essayer ma méthode, avais-tu déja essayé une autre méthode? Laquelle?

#60 Le 10/01/2007, à 15:07

NelsonCherico

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Salut,
D'abord un grand merci à vous deux pour ce travail de titan...
Le vrai béotien que je suis ne sait pas, concrètement, que je faire ? Je m'explique : plusieurs fois déjà j'ai essayé d'installer des paquets, je les dépose sur mon bureau, ensuite je vais dans un terminal et je tape les lignes de commande indiquées et... il ne se passe jamais rien ! Pourquoi ? Qu'est-ce que je ne sais pas faire ? Le seule chose qu'Ubuntu a semble-t-il faite, c'est d'installer firmwares.deb, et encore parce qu'avec un clic droit j'ai vu qu'il y avait un gestionnaire de paquets deb et que je l'ai actionné. Il semble que ça fonctionne car la diode ADSL du Sagem 800 E3 est allumée alors qu'elle ne l'était pas avant. Mais il n'y a pas moyen de me connecter... Quand aux paquets ueagle-atm-2.6.17-10-generic.deb qui correspondent à mon Ubuntu 6.10 téléchargé par Bittorrent, impossible de les installer!!! Au secours!
Ar Louarn

Dernière modification par arlouarn48 (Le 10/01/2007, à 16:47)


Homme libre toujours tu chériras la mer... et Ubuntu (librement adapté)

Hors ligne

#61 Le 10/01/2007, à 16:54

Valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

arlouarn48 a écrit :

(...)il ne se passe jamais rien ! Pourquoi ? Qu'est-ce que je ne sais pas faire ?
Ar Louarn

Si ! il se passe toujours quelques chose... c'est comme aux Galeries Lafayette !
Saisir et valider une commande entrainne obligatoirement une réponse... surtout si la commande n'aboutit pas smile 
- télécharge les paquets correspondants a ta distribution... puis si ils sont sur ton bureau créer un dossier (ex :Sagem), déplacer les "paquets" Debian vers le dossier Sagem.
- Ouvrir un termimale et saisir :

ls Sagem

pour obtenir la liste des fichiers du dossier Sagem.
- Pour aller dans le dossier "Sagem"

cd Sagem

suivre ensuite simplement la procédure smile

@+

#62 Le 10/01/2007, à 19:57

NelsonCherico

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Je dois être très idiot... J'ai fait ce que tu préconises, c'est-à-dire créer un dossier appelé Sagem que j'ai laissé sur le bureau, j'y ai mis le paquet ueagle-atm-2.6.17-10-generic.deb. Ensuite j'ai ouvert mon terminal et j'ai fait
ls Sagem
la réponse est :
ls Sagem: aucun fichier ou répertoire de ce type.
Je me rends bien compte qu'il y a une différence entre "dossier" et "fichier ou répertoire" mais je n'ai trouvé nulle part où il faut aller pour créer un fichier... Je regrette d'encombrer le forum pour ça, mais je suis vraiment bloqué et tant que je n'aurai pas internet, Ubuntu ne me servira pas beaucoup...


Homme libre toujours tu chériras la mer... et Ubuntu (librement adapté)

Hors ligne

#63 Le 11/01/2007, à 01:02

bouillard

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,
Je suis nouveau dans le monde Ubuntu. J'ai une version v6.06.1 DAPPER.
J'ai suivi la méthode CATHOU. Le modem Fast Sagem 800 est reconnu, il se synchronise mais il y a une erreur de ping à la connexion. Noyau 2.6.15-26-386
Merci de votre attention!

#64 Le 11/01/2007, à 09:56

Valente

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Bonjour,

arlouarn48 a écrit :

Je dois être très idiot...

... Je crois t'avoir brillamment devancé a ce jeux là ! Il fallait comprendre, avec un bureau Kubuntu :

ls Desktop/Sagem/

et

cd Desktop/Sagem/

Avec mes excuses.

bouillard a écrit :

il se synchronise mais il y a une erreur de ping à la connexion

Questions : tu as le "ouaibe" ? Merci de faire un copier/coller des infos affichés par "connexion-diagnostic"

@+

#65 Le 11/01/2007, à 12:12

NelsonCherico

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Chapeau!!! Merci Valente de m'avoir ainsi guidé pour me connecter; et merci à Cathou dont j'ai pris le modèle...
Juste une question (bien entendu je vous écris depuis Ubuntu, preuve que je suis connecté) après l'installation, j'ai accepté la connexion diagnostic, toutes les questions ont eu la réponse adéquate... et pourtant le message s'est terminé par "erreur de ping". Pourtant je suis connecté. D'accord, je n'arrive pas à expédier de messages encore mais je reçois tout et je navigue sur le Ouaibe.
Pouvez-vous me dire ce qui ne va pas ?


Homme libre toujours tu chériras la mer... et Ubuntu (librement adapté)

Hors ligne

#66 Le 11/01/2007, à 16:16

blowup

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

J'ai décidé de changer de méthode même si tout fonctionnait bien.

La seule raison qui a motivé ce choix sont les commandes

pon

et

poff

fournies par Cathou.

Je coupe donc ma connexion et je désinstalle les paquets "Valente":

sudo apt-get remove --purge atm-tools_2.4.1-17_i386.deb 
sudo apt-get remove --purge  eagleFirmware.deb

Je débranche le modem  ( WA ) pour vider la mémoire de ce celui-ci ( c'est un usb hein évidement )
J'installe les nouveaux paquets pour une connexion Orange/Wanagro

sudo dpkg -i ueagle-atm-firmwares.deb ueagle-atm-2.6.17-10-generic-386.deb ueagle-ppoa.deb

suivi de

sudo connexion-config

synchronisation et connexion tout baigne.

Je reboot pour verifier que tout se lance bien au démarrage , impeccable

Je me dis tiens je vais essayer les petites commandes magiques

poff

me renvoie un

/usr/bin/poff: /bin/kill failed.  None stopped.

je fais un 

sudo modem-diagnostic

:

Distro:                         Ubuntu 6.10
Noyau actuel:                   2.6.17-10-generic
Noyau(x) installé(s): 
2.6.17-10-generic       (2.6.17.1-10.34)
generic (2.6.17.10)

Pilote pour noyau actuel:       [ok]
Présence firmwares:             [ok]
Absence eagle-usb sur disque:   [ok]
Absence eagle-usb en mémoire:   [ok]
Présence ueagle-atm en mémoire: [ok]

FATAL: Module usbatm is in use.
Tentative de synchronisation du modem - Patientez SVP...

Chipset: Eagle I

Le modem est fonctionnel - Synchro en 16 secondes.

suivi de

sudo connexion-diagnostic
:
ppp0:                 [ok]
ping:                 [KO]
résolution de noms:   [KO]

suivi d'un

ifconfig
lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:509 erreurs:0 :0 overruns:0 frame:0
          TX packets:509 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:602928 (588.7 KiB) Octets transmis:602928 (588.7 KiB)

Tiens je suis déconnecté

j'essaie

pon

nikel il me renvoie 

Plugin pppoatm.so loaded.

Alors les questions sont :
Pourquoi poff ne marche pas ?
Est-ce qu'en prime je n'aurai pas un module en trop qui traîne dans mon noyau? ai-je loupé quelquechose?

Donc pour que l'on me réponde au mieu et en passant filer un retour d'infos bien complet wink :

lsmod | grep eagle
ueagle_atm             27816  0 
usbatm                 20864  2 ueagle_atm
usbcore               134912  4 ueagle_atm,usbatm,uhci_hcd
modinfo ueagle_atm
filename:       /lib/modules/2.6.17-10-generic/kernel/drivers/usb/atm/ueagle-atm.ko
author:         Damien Bergamini/Matthieu Castet/Stanislaw W. Gruszka
description:    ADI 930/Eagle USB ADSL Modem driver
license:        Dual BSD/GPL
vermagic:       2.6.17-10-generic SMP mod_unload 586 REGPARM gcc-4.1
depends:        usbcore,usbatm
alias:          usb:v05CCp3351d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v05CCp3350d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9010d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p900Fd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9022d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9021d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9024d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9023d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9032d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1110p9031d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F2d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F1d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00FAd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F9d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F6d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F5d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F8d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BAFp00F7d*dc*dsc*dp*ic*isc*ip*
srcversion:     656B9FF709AB3FF09C51E8D
parm:           cmv_file:file name with configuration and management variables (array of charp)
parm:           sync_wait:wait the synchronisation before starting ATM (array of bool)
parm:           use_iso:use isochronous usb pipe for incoming traffic (array of bool)
parm:           debug:module debug level (0=off,1=on,2=verbose) (uint)

En tout cas j'ai le net c'est le principal , mais je les trouvai sympas ces petites commandes ppon et poff.
Et puis je peux toujours couper la connexion avec

sudo /etc/init.d/ueagle-pppoa stop

mais c'est moins que si c'était mieux wink

Et puis sinon encore une fois c'est du bon boulot vos paquets.

Hors ligne

#67 Le 12/01/2007, à 00:33

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Mazette! ça c'est du retour smile

Est-ce qu'en prime je n'aurai pas un module en trop qui traîne dans mon noyau?

Non, ton modem-diagnostic est correct. Le pilote n'est pas en cause.

Peux-tu faire un connexion-diagnostic immédiatement après avoir booté (c'est à dire: sans faire modem-diagnostic) et rapporter s'il est différent de celui que tu as constaté?

Hélas, tu n'auras pas une solution à très court terme. Dans l'attente, je te suggère de substituer à la commande poff:

soit celle-ci:

poff -a

soit celle-là:

poff provider

Accessoirement, ce serait bien si tu pouvais préciser, parmi les paquets suivants, ceux qui sont installés sur ton système:

pppconfig
pppoe
pppoeconf
pppstatus

.. il suffit d'une visite dans Synaptic (ou Adept) smile

ai-je loupé quelquechose?

Pas du tout.

#68 Le 12/01/2007, à 02:07

blowup

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Y  a qu'a demander ...


 sudo connexion-diagnostic

ppp0:                 [ok]
ping:                 [KO]
résolution de noms:   [KO]

Il est fort probable que le ping et autre icmp soit bloqués par ma config firestarter, donc Iptables -L ,  ce qui est a prendre en compte ou pas.

au mieux je peux confirmer par MP a coup de Iiptable -L ( c'est mon choix comme sur france 3 )

poff -a
/usr/bin/poff: /bin/kill failed.  None stopped.

mais j'avais essayé en lisant la manpage hehehe hmm tongue super bien d'ailleurs !

 poff provider
/usr/bin/poff: /bin/kill failed.  None stopped.

bon ben là je fais moins le malin j'avais pô essayé wink

miaintenant les resultats de

dpkg -l | grep

avec coloration  siouplé (pour moi hein mai comme ça tu es sûr(e)? ; ba ui au fait cathou c qui ? )

dpkg -l | grep

et dans l'ordre donné :

dpkg -l | grep pppconfig

* ii  pppconfig                             2.3.12ubuntu1                        A text menu based utility for configuring pp

dpkg -l | grep pppoe

* ii  pppoeconf                             1.10ubuntu3                          configures PPPoE/ADSL connections

dpkg -l | grep pppoeconf

* ii  pppoeconf                             1.10ubuntu3                          configures PPPoE/ADSL connections

dpkg -l | grep pppstatus

* quedalle

Bon n'hésites pas à demander plus d'info je sais plus si c'est avec valente ou toi qu'on en a parlé de ce même topic par mail , voir page 1 à mon souvenir.

En tout cas si cela peut aider c'est un plaisir et cela sera forcément bénéfique pour d'autres

Je traîne encore par là un bout de temps sinon à tantôt

ps:mais c'est qui cathou ^^? en tout bien tout honneur c'est pour l'orthographe... smile smile

Hors ligne

#69 Le 12/01/2007, à 16:47

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Houla. C'est pas normal que le poff -a échoue yikes

Du coup j'ai un doute. Tu disais:

Je reboot pour verifier que tout se lance bien au démarrage , impeccable

Es-tu vraiment certain de bien être connecté dès le démarrage?
Attention, si tu utilises Firefox il se peut qu'il te renvoie des pages qui se trouvent dans son cache, te donnant l'illusion d'être connecté.

Essaie plutôt ceci:

ping -c 3 193.252.149.30
ping -c 3 www.orange.fr

immédiatement après avoir booté.

Si les pings ne répondent pas alors ce n'est pas étonnant que poff, dans chacune des trois variantes, te renvoie ce message.

Un autre truc un peu vicieux qu'il faut savoir sur poff, c'est que la déconnexion n'est pas immédiate. Il faut attendre jusqu'à parfois 15 secondes avant que le kill agisse sad

Si tu as le temps, tu peux également essayer de voir si les choses se passent de la même manière quand tu bootes en mode 'recovery'.
Je te rappelle que tu es root dans ce mode. Mais bon, je suis sûre que tu sais ce que tu fais..

Tes déboires me font penser que dans la prochaine version du paquet, j'incorporerai deux commandes à moi du genre ion/ioff avec des messages non ambigus et en français wink à utiliser en lieu et place des pon/poff natifs.

Merci.

Dernière modification par Cathou (Le 12/01/2007, à 16:49)

#70 Le 13/01/2007, à 08:00

blowup

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Cathou ,

Es-tu vraiment certain de bien être connecté dès le démarrage?
Attention, si tu utilises Firefox il se peut qu'il te renvoie des pages qui se trouvent dans son cache, te donnant l'illusion d'être connecté.

Oui j'en suis sûr , d'autant que me logue en console avant de lancer X, et donc un petit

ifconfig

me le confirme. Je viesn d'essayer ce matin.

Pour les problèmes de cache rassures-toi je n'en ai pas , quelque soit le navigateur, je les vide les caches pour un tas de raison que je n'explique pas ici.

C'est pas normal que le poff -a échoue

Alors si cela peut faire avancer le shmili, le shimilimili, bref , sache que

sudo poff

marche impec chez moi et immédiatement.

Essaie plutôt ceci:

ping -c 3 193.252.149.30
ping -c 3 www.orange.fr

Bon

ping -c 3 www.orange.fr
PING www.orange.fr.multis.x-echo.com (193.252.122.103) 56(84) bytes of data.

--- www.orange.fr.multis.x-echo.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2010ms

Maintenant je suis sûr et certain d'une chose, je bloque l'entrée des pings avec ma config firestarter, que je n'ouvre jamais et que je n'ouvrirai pas ici, mais je pense que cela réponds à ta  question.

tes déboires me font penser que dans la prochaine version du paquet, j'incorporerai deux commandes à moi du genre ion/ioff avec des messages non ambigus et en français  à utiliser en lieu et place des pon/poff natifs.

Hum et pourqoi pas une commande plus simple encore : adsl/stopadsl ou adsl/noadsl après tout c'est plus clair.

Bon en tous cas j'ai le net, je peux me connecter et me déconnecter facilement ( pon / sudo poff) donc tout va bien.
Et puis là au risque de te décevoir je ne ferai pas les tests en mode recovery, mais je testerai à fond les prochaines versions des paquets si tu veux.

En tous cas merci d'avoir suivis tout cela et en éspérant que cela te soit utile pour la suite.

Ciao

Dernière modification par blowup (Le 13/01/2007, à 08:02)

Hors ligne

#71 Le 13/01/2007, à 12:09

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Merci beaucoup.

Ceci démontre qu'il me faudra mettre en place quelque chose de plus évolué qu'un double ping dans la prochaine version de connexion-diagnostic wink

@+

#72 Le 13/01/2007, à 16:00

NelsonCherico

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Salut,
Malgré l'absence de ping, je suis connecté normalement en émission et réception avec Thunderbird.
Fin de l'histoire pour moi et un réel merci à vous qui vous décarcassez pour nous.
Pour ma part, je vais apporter mon soutien au prochain manuel en le corrigeant.


Homme libre toujours tu chériras la mer... et Ubuntu (librement adapté)

Hors ligne

#73 Le 13/01/2007, à 20:45

Cathou

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Malgré l'absence de ping, je suis connecté normalement en émission et réception avec Thunderbird.

L'essentiel est que ton accès à internet soit correct. Dans la prochaine version du paquet pppoa, le programme connexion-diagnostic gagnera en robustesse et ces soucis de 'faux négatifs' seront réglés.

Pour ma part, je vais apporter mon soutien au prochain manuel en le corrigeant.

De quel manuel parles-tu?

#74 Le 21/01/2007, à 21:54

pmdzlineur

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

une installation de sagem 800 sur un oridi avec edgy n' égale pas une autre sur un autre ordi smile
j' ai enfin réussi à installer ueagle-atm, mais je suis obligé malgré tout de faire un modprobe -f à chaque fois, je ne comprend pas pourquoi .
Peut-être parce que je suis sous une version edgy généric (mais je ne vois pas pourquoi)
M'enfin, ça marche ...


je ne suis pas informaticien, juste utilisateur un peu averti ;-)
http://www.freemedforms.com/fr/start
http://code.google.com/p/rapidcomptamed/
médecin volant, mais pas en même temps ;-)

Hors ligne

#75 Le 24/01/2007, à 23:05

MrZeroo00

Re : Sagem F@st 800 USB facile sous Ubuntu (Dapper à Natty Narwhal)

Merci , ça marche , avec la méthode de Cathou , je suis entrain de poster sous Ubuntu Live CD . mon FAI est Maroc Telecom big_smile .

Dernière modification par MrZeroo00 (Le 24/01/2007, à 23:36)

Hors ligne

Haut de page ↑