Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#51 Le 20/09/2010, à 19:00

cris22

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour

Je viens trouver ce post

J'avais un problème de son avec les videos sur firefox (echo, impression de 5.1 mal réglé) et ce depuis les deux dernières versions Ubuntu.

Eric S, le 01/08/2008, dit avoir modifié le fichier .asoundcr dans /home, j'ai suivi son exemple en renommant ce fichier .asoundrc-old.

et là impeccable le son est maintenant clair et limpide

Je ne sais pas si j'ai bien fait, mais depuis le temps que je cherche une solution, je tenais à remercier Eric S et remettre à jour cette soluce

Merci


Ubuntu 14.04 LTS - 64 bits - Unity
Mémoire : 3.9 Gio - Carte : GeForce 8600 GTS/PCIe/SSE2
Processeur : Intel® Core™2 Quad CPU Q9550 @ 2.83GHz × 4

Hors ligne

#52 Le 21/09/2010, à 13:11

Anarkopsykotik

Re : [A lire avant de poster] Résolution des problèmes de sons

Je suggère (vu que ça m'a bien fait galérer, ce truc écrit en tout petit tout en bas) de rajouter à côté du tuto pulse audio "Ne pas s'en occuper sous KDE" ou quelque chose du style.


"Touche pas au grisby salope!"

Hors ligne

#53 Le 26/09/2010, à 10:05

nico2nice

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjours tout le monde ... Avant d'expliqué mon souci je tiens a m'exuser je suis tout sauf un specialiste linux ... par curiosité j'ai ecouté un ami qui m'a dit que du bien de Ubuntu et j'avoue que depuis j'ai plus de souci... sauf ma carte son ...
j'ai un ordi compaq CQ61-207SF et impossible de trouver un driver pour qu'il fonctionne correctment j'ai pas de son entrant comme sortant
qd je vais dans Administration il ne me trouve rien ...
et j'avoue que sa fait plus de 3 jours que je cherche sur google et trouve rien ... ou comprend rien dans les ligne de commande ...
donc un petit coup de main une direction a prendre je suis preneur
merci a tous ^^

Hors ligne

#54 Le 03/10/2010, à 22:26

CaptainZorba

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour,

Comment puis je faire pour savoir si j'ai Alsa ou Pulseaudio? D'ailleurs qu'est ce que c'est Alsa et Pulsaudio? Comment faire pour savoir si je dois suivre le premier, le deuxième tutoriel ou bien les deux?

Hors ligne

#55 Le 31/12/2010, à 14:52

Queff

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour,
J'ai galéré pour récupérer le son après avoir passé à la version ubuntu 10.10. J'avais le son par intermittence.
Après avoir supprimé pulseaudio et installé ALSA et plusieurs de ses composants, enfin cela à l'air de marcher.
Problème, quand je fais : système/préférence/son, rien ne marche et il me renvoie un message "attente de réponse du système sonore".
Par ailleurs, j'ai perdu l'icône de réglage du volume sur mon tableau de bord.
Comment puis je récupérer ces deux fonctions ?
Merci d'avance


Ubuntu 14.04 LTS sur portable ASUS R510C Séries, Intel core I7-3537UCPU 2GHzx4, OS 32b NVIDIA GeForce 720 M

Hors ligne

#56 Le 02/01/2011, à 11:01

Queff

Re : [A lire avant de poster] Résolution des problèmes de sons

Laissez tomber... d'impatience j'ai réinstallé ubuntu et tout est revenu dans l'ordre
Merci


Ubuntu 14.04 LTS sur portable ASUS R510C Séries, Intel core I7-3537UCPU 2GHzx4, OS 32b NVIDIA GeForce 720 M

Hors ligne

#57 Le 14/01/2012, à 19:03

duran1983

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour,

je n arrive pas  moment  a ecouter le son sur mon Ordinateur et sur Internet depuis l actuatlisation de mon acien Unbutu a Unbutu one. j ai pourtant Adobe Flash plugin 10 installe  installe. j ecoute les fichiers qui sont sur l ordinateur  avec Banshee ou Rhytmbox .  il ya des temps ou j ai le son sans problem et ceux dont  la music jout mais il n y a pas de son.

salut

Hors ligne

#58 Le 06/02/2012, à 16:48

HDThoreau

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour,

le premier document ma sauvé

merci

HDThoreau

Hors ligne

#59 Le 06/03/2012, à 14:52

Papylle77

Re : [A lire avant de poster] Résolution des problèmes de sons

Liste des codecs reconnus par ffmpeg

Sur la page "http://doc.ubuntu-fr.org/ffmpeg", il est dit qu'en lançant la commande :
ffmpeg -codecs
on doit obtenir la liste des codecs reconnus par ffmpeg.

Or si je lance cette commande avec ma version de ffmpeg 4:0.5.1, je n'obtiens pas cette liste mais seulement un message d'erreur : ffmpeg: missing argument for option '-codecs'
alors que j'obtiens bien la liste des codecs (précédée de la liste des formats) en lançant la commande :
ffmpeg -formats

Est-ce normal, ou n'ai-je rien compris ?

Je suis sous Ubuntu 10.4 LTS

Dernière modification par Papylle77 (Le 06/03/2012, à 15:16)


vive l'internet coopératif !
:P

Hors ligne

#60 Le 06/03/2012, à 15:06

Papylle77

Re : [A lire avant de poster] Résolution des problèmes de sons

Codecs libx264 et libvpx ?

Sur la page "http://doc.ubuntu-fr.org/ffmpeg", il est question notamment (au paragraphe § 3.7) des codecs libx264 et libvpx ;
or en lançant la commande :
ffmpeg -formats
qui fournit la liste des formats gérés ainsi que la liste des codecs reconnus, je ne trouve nulle part ni libx264, ni libvpx, ni d'ailleurs x264, ni vpx.

S'agit-il d'un problème de version de ffmpeg (j'utilise ffmpeg 4:0.5.1 sous Ubuntu 10.4 LTS) ou serait-ce que la documention de ffmpeg n'est pas à jour ?

Dernière modification par Papylle77 (Le 06/03/2012, à 15:17)


vive l'internet coopératif !
:P

Hors ligne

#61 Le 06/03/2012, à 15:16

Papylle77

Re : [A lire avant de poster] Résolution des problèmes de sons

relation entre conteneurs (extension) et codecs

Sur la page "http://doc.ubuntu-fr.org/ffmpeg", il est question notamment (au paragraphe § 3.3) du choix du conteneur.

La documention de ffmpeg fournit (grâce à la commende ffmpeg -formats) la liste des codecs
mais cette même documentation n'indique pas (ou je n'ai pas su la trouver) qu'un fichier de sortie à extension *.mkv sera automatiquement codé avec le codec matroska.

Est-il possible de connaître les relations existant ainsi entre chacun des conteneurs reconnus par ffmeg et le codec que ffmpeg lui associera automatiquement (ou, s'ils sont plusieurs, les codecs qu'il considère comme compatibles avec chacun des conteneurs) ?

J'utilise ffmpeg 4:0.5.1 sous Ubuntu 10.4 LTS.

Dernière modification par Papylle77 (Le 06/03/2012, à 15:19)


vive l'internet coopératif !
:P

Hors ligne

#62 Le 20/03/2012, à 18:24

Thalyn

Re : [A lire avant de poster] Résolution des problèmes de sons

Salut,


Ce n'est pas vraiment le bon endroit pour en parler, car ce sujet concerne les problèmes de (gestion du) son du type Alsa, OSS, OSS4, Puleaudio etc...
Mais bon, vu que tu as l'air sympa (à première vue en tout cas), je vais faire preuve de très grande générosité avec très grande modestie en te répondant big_smile
Quoique depuis le temps, que tu as posté tes messages, tu as dû trouver tes réponses.

Non en fait je réponds, car j'aime pas faire un message sans apporter d'abord (et quand je le peux) une réponse (possible) au message précédent.


Plus sérieusement :

Papylle77 a écrit :

Liste des codecs reconnus par ffmpeg

Sur la page "http://doc.ubuntu-fr.org/ffmpeg", il est dit qu'en lançant la commande :
ffmpeg -codecs
on doit obtenir la liste des codecs reconnus par ffmpeg.

Or si je lance cette commande avec ma version de ffmpeg 4:0.5.1, je n'obtiens pas cette liste mais seulement un message d'erreur : ffmpeg: missing argument for option '-codecs'
alors que j'obtiens bien la liste des codecs (précédée de la liste des formats) en lançant la commande :
ffmpeg -formats

Est-ce normal, ou n'ai-je rien compris ?

Je suis sous Ubuntu 10.4 LTS

Je suis sous Kubuntu 11.10, je ne peux donc pas te répondre avec certitude car ma version de ffmpeg est la 0.7.3-4:0.7.3-0ubuntu0.11.10.1
A première vue, cela ne semble donc, pas normal. A moins que cette commande ne soit pas implémenté dans "ta" version de ffmpeg (et ubuntu 10.04), mais j'en doute.
Car ces 2 commande sont deux chose différentes mais complémentaires.
L'une indique les codecs gérés,
L'autre les formats gérés.

J'ai ce message :
ffmpeg: missing argument for option '-codecs'
Uniquement si je tape ffmpeg --codecs (avec les 2 -), sinon en tapant (correctement) la comande "ffmpeg -codecs" je n'ai pas ce message et ma liste s'affiche correctement.

Alors si tu es certain de ne pas t'être trompé en tapant la commande, je me demande alors si tu ne devrais pas retenter une ré-installation de ffmpeg pour "bien faire".


Papylle77 a écrit :

Codecs libx264 et libvpx ?

Sur la page "http://doc.ubuntu-fr.org/ffmpeg", il est question notamment (au paragraphe § 3.7) des codecs libx264 et libvpx ;
or en lançant la commande :
ffmpeg -formats
qui fournit la liste des formats gérés ainsi que la liste des codecs reconnus, je ne trouve nulle part ni libx264, ni libvpx, ni d'ailleurs x264, ni vpx.

S'agit-il d'un problème de version de ffmpeg (j'utilise ffmpeg 4:0.5.1 sous Ubuntu 10.4 LTS) ou serait-ce que la documention de ffmpeg n'est pas à jour ?


Pour la commande "ffmpeg -codecs", libx264, libvpx correspond aux codecs installés (Mastroska n'est pas un codec, mais un format/conteneur et ne figure donc pas dans cette liste):

Codecs :
D..... = Decoding supported (Lire)
.E.... = Encoding supported (Écrire)
..V... = Video codec (codec Vidéo)
..A... = Audio codec (codec Audio)
..S... = Subtitle codec (Codec de SsTitre)
...S.. = Supports draw_horiz_band
....D. = Supports direct rendering method 1
.....T = Supports weird frame truncation

DEVASSDT

DEV      D      h261                 H.261
DEV  S  DT   h263                  H.263 / H.263-1996
D  V  S  D      h263i                 Intel H.263
  EV               h263p                H.263+ / H.263-1998 / H.263 version 2
D  V      D      h264                  H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
D  V      D      h264_vdpau      H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (VDPAU acceleration)
...
...
D  V  S  D    vp3                      On2 VP3
D  V      D    vp5                      On2 VP5
D  V      D    vp6                      On2 VP6
D  V      D    vp6a                    On2 VP6 (Flash version, with alpha channel)
D  V      D    vp6f                     On2 VP6 (Flash version)
D  V      D    vp8                      On2 VP8
D  V  S  D    vp3                      On2 VP3
D  V      D    vp5                      On2 VP5
D  V      D    vp6                      On2 VP6
D  V      D    vp6a                    On2 VP6 (Flash version, with alpha channel)
D  V      D    vp6f                     On2 VP6 (Flash version)
D  V      D    vp8                      On2 VP8
...
...
DEV          libvpx                    libvpx VP8
   EV           libx264                 libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
...

À noter (si je ne dis pas de bêtise) que les h26x (en particulier le h264 ici)  sont gérés par défaut par ffmpeg, mais la libx264 installe (en plus) un encodeur externe (qui serait plus performant que celui par défaut) qui gère donc aussi le codec h264.
Et... Il y'en a peut-être d'autres, je ne connais pas tous les codecs gérés par ces librairies.


Pour la commande "ffmpeg -formats", libx264, matroska (.mkv) correspondent à (libvpx ne gère pas de formats à ma connaissance, seulement les codecs VPx) :

Formats de fichier :
D. = Demuxing supported (lire)
.E = Muxing supported (écrire)


DE            h261                    raw H.261
DE            h263                    raw H.263
DE            h264                    raw H.264 video format

DE            matroska             Matroska file format
D              matroska,webm   Matroska/WebM file format

Papylle77 a écrit :

relation entre conteneurs (extension) et codecs

Sur la page "http://doc.ubuntu-fr.org/ffmpeg", il est question notamment (au paragraphe § 3.3) du choix du conteneur.

La documention de ffmpeg fournit (grâce à la commende ffmpeg -formats) la liste des codecs
mais cette même documentation n'indique pas (ou je n'ai pas su la trouver) qu'un fichier de sortie à extension *.mkv sera automatiquement codé avec le codec matroska.

La doc ne semble pas avoir été modifié depuis ton message. Mais c'est précisé ici :[doc]http://doc.ubuntu-fr.org/ffmpeg#instruction_generale[/doc]

doc.ubuntu-fr > ffmpeg > Instruction générale a écrit :

Le conteneur est choisi automatiquement via l'extension du fichier. C'est-à-dire que si le fichier final se termine par .mkv le format sera automatiquement mis en matroska sans vous demander votre avis.

Papylle77 a écrit :

Est-il possible de connaître les relations existant ainsi entre chacun des conteneurs reconnus par ffmeg et le codec que ffmpeg lui associera automatiquement (ou, s'ils sont plusieurs, les codecs qu'il considère comme compatibles avec chacun des conteneurs) ?

J'utilise ffmpeg 4:0.5.1 sous Ubuntu 10.4 LTS.

Ouep en effet, ce serait pratique ce type de commande ou (logiciel) qui nous permettrait d'afficher ce type de concordances logiciel de lecture/encodage > conteneurs (format) > codecs.

Faudrait regarder dans les options de ffmpeg, peut-être le permet-il.
En sachant qu'on peut le faire finalement en comparant les deux commandes "ffmpeg - codecs" et "ffmpeg -formats", mais faut déjà savoir les lire, les comprendre .... et qu'une les deux commandes fonctionnent (lol).

-------

Sinon je passais ici pour proposer une solution pour les problème de son.
Solution qui résoudrait 90% des problèmes des sons (si la carte/puce est reconnue et que les canaux ne sont pas en sourdine).

J'ai déjà fait un sujet sur le forum, mais visiblement personne n'a essayé (mis à part moi à deux reprises sur la 11.04 et la 11.10, avec succès).
Les problèmes de son peuvent souvent provenir d'un changement de Kernel (entre autres).
La solution est alors de passer AlsaMixer en 1.0.25 (1.0.24 par défaut dans K/Ubuntu) via un script trouvé sur ubuntuforum.org, qui permet de mettre à jour AlsaMixer, d'installer toutes les "outils" en 1.0.25 et de compiler le tout avec le Kernel.
J'ose imaginer que si le son "saute" après avoir monté un nouveau Kernel, il suffirait alors de relancer le script (Alsa-xxx sont installés dans le dossier /opt/Alsa-1.0.25/).

Voici le sujet : [Info] Perte de son | Kernel 2.6.38-13-generic

Ne pas tenir compte de la seconde partie du titre, puisque mon problème concernait un problème de son apparu visiblement, après la passage du kernel 2.6.38-12-generic au 2.6.38-13-generic.
Mais la manip fonctionne pour tous Kernel.
J'aurai pu revenir tout simplement à la version précédente pour résoudre mon soucis. Mais j'avais préféré continuer avec ce kernel et "essayer" cette solution.

En clair, si vous avez un soucis de son, lié à votre "dernière" version de Kernel, au lieu de tout ré-installer bêtement la distro et de perdre 1-2heures (à la manière de 90% des gens du forum qui rencontrent ce soucis), soit vous redémarrez l'ordi à la version précédente du kernel, soit vous utilisez cette solution ici (je rappel le lien)  : [Info] Perte de son | Kernel 2.6.38-13-generic

@+

Dernière modification par Thalyn (Le 20/03/2012, à 18:31)

Hors ligne

#63 Le 05/11/2013, à 14:13

voxpopuli

Re : [A lire avant de poster] Résolution des problèmes de sons

Je souhaite juste signaler un bug (de plus) sur le nouveau xubuntu 13.10
Lors de certains démarrage, étrangement pas a chaque, le son des lecteurs audio (vlc, media parole et autre) ne sort que sur les baffles branchés à la sortie son de l'écran HDMI.
Modifier les options sonores n'amène strictement aucune modification au système en cours (si, une fois j'ai dû redémarré j'avais totalement perdu le son).

Edit: bon ben étrangement depuis aujourd'hui chaque démarrage avec l'écran HDMI branché dés le début amène ce bug. Par contre démarrer sans l'écran permet de modifier les options sonores par après pour envoyer le son vers la sorties préférées (pc, hdmi, etc)

Dernière modification par voxpopuli (Le 05/11/2013, à 14:32)


« Si la destinée ne nous aide pas, nous l'aiderons nous même à se réaliser !  »
$Wold.Action.Boot();

Hors ligne

#64 Le 07/02/2014, à 01:26

L4nC3r

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour, je me tourne vers vous après avoir lu et essayer beaucoup de techniques, mon problème, le micro interne de mon pc, je parle dedans et rien ne se passe, je pensais au début qu'il s'agissait d'un problème seulement lier à skype, mais non, donc j'ai bien le son sur les videos, c'est sûrement un problème de réglage, quelqu'un peut-il m'aider?

Hors ligne

#65 Le 25/04/2014, à 16:43

jptzd

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour
Apres une nouvelle install pas de son dans lubuntu.
Pour regler le problème j'ai telecharge le paquet pavucontrol dans synaptic.
ensuite dans son et video on a une nouvelle rubrique qui s'appelle:controle du volume pulse audio.
cliquer dessus et aller a configuration et la changer et mettre:
surrond analogique 5.1 sortie+stereo analogique entrée
le son revient.
j'espère que ça pourra depanner pas mal de gens qui n'ont plus de son

Hors ligne

#66 Le 03/07/2014, à 13:37

misstermoustache

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjours !!! Je vient d'installer Ubuntu 14.04 j'ai mis tout à jour comme conseiller sur des tuto mise à pare les logicièls (multiverse) les préversion et les non gérées.
Mais j'ai vraiment un très gros souci de sons sa grési à des que je rentre dans ma sessions de Ubuntu et qu'an je mais le sons très fore sa donnes un écos et des craquement.
Si vous pouvez me rediriger et m'aider. je sais pas me servir du forum pour résoudre mon souci.
Je suis sur un HP pavilion dv7. sad

Hors ligne

#67 Le 09/08/2014, à 23:07

Sisiphe

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonsoir
Je fonctionne avec Ubuntu 12.04 LTS;  j'ai téléchargé la mise à jour le 24 juillet.
J'enregistre des émissions Radio France que je conserve , en fichier MP3 sur mon DD et je les écoutais en utilisant l'application RHYTHMBOX.
je constate aujourd'hui que je ne peux plus écouter ces fichiers Il semble que le système ne trouve plus cette application,.
Pourtant, le test 'son" est bon; et je peux écouter les émissions en streaming.
Je n'ai pas trouvé dans le forum, de réponse concernant cette situation!
Quelqu'un peut il m'aider?
Merci

Hors ligne

#68 Le 06/09/2014, à 09:44

kliff

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour,
Pour information, réinstaller simplement VLC ou le mettre à jour résout beaucoup de problèmes liés au son, j'ai rencontré un problème avec les enregistrements vidéos que je faisais à l'aide de ce type de camera. De mon côté, les problèmes sonores viennent souvent de VLC, peut-être que c'est aussi le cas pour vous, pensez à vérifier votre version.

__________________________________________________________________________
Site web : 123

Dernière modification par kliff (Le 22/10/2014, à 00:57)

Hors ligne

#69 Le 04/11/2014, à 16:57

Guepard58

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour à tous.

Comment faire pour obtenir un son constant de même intensité pour la lecture de mp3 encodé de differente maniére. (14.04) avec rythmbox.  Merci pour vos réponses.

Hors ligne

#70 Le 17/12/2014, à 10:38

degolarson

Re : [A lire avant de poster] Résolution des problèmes de sons

Bonjour
une petite manip toute simple à tenter avant de s'embarquer dans des galères
voyez ici au #8  : couper le son puis le remettre

Dernière modification par degolarson (Le 17/12/2014, à 10:40)


xp / Xubuntu 12.04.5  32b     xfce 4.8.6         Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009    Freebox V5
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285   
Audio device: Intel  82801I (ICH9 Family) HD Audio Controller (rev 03)
Doucement, nous sommes pressés !

Hors ligne

Haut de page ↑