Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/12/2017, à 12:49

lobo1512

[TUTO] Module carte wifi realtek rtl8723be

De nombreux topik parlent de problèmes relatifs à cette carte, assez mal supporté par les distri basé Débian, mais que l'on parviens à faire fonctionner correctement ou parfaitement (selon les pc et les configs) sous ubuntu 16.04 et toutes les distri basés Débian .
Dans les divers topik traitant de ce sujet, plusieurs solutions sont proposé, à savoir :
- Un simple update/upgrade suivit d'un réglage des options d'antenne et d'interdiction de mise en veille de la carte.
- Un script proposé par metalux qui modifie le comportement de la carte suivit d'un réglage des options .
- L'installation du hanipouspilotPPA suivit d'un réglage des options.
- La compilation du module présent dans un dépot github suivit d'un réglage des options.

Après avoir testé les 3 solutions sur plusieurs distri basé Débian, il semble que la solution qui fonctionne le mieux avec mon pc et ma config soit de compiler le module, mais ce n'est pas toujours le cas.
Donc je proposerai les différentes solutions qui peut-être conviendront mieux à votre config.

Il faudra que vous essayez les différentes solutions pour trouver ce qui fonctionne le mieux chez vous. Je vous conseille de tenter en premier lieu la solution du update/upgrade puis celle du script de metalux car ce sont des solutions qui conservent le module par défaut. Si ça ne fonctionne pas, essayez de compiler le module git et en dernier recours utiliser le PPA après avoir préalablement supprimé le module git compilé afin qu'ils ne rentrent pas en conflit .

Le tuto se compose en 3 paragraphes :
- Les différentes solutions proposés.
- Les options de paramétrage de la carte.
- Un ajout concernant une erreur récurrente du grub.

Les différentes solutions proposées

1ere solution proposé : update/upgrade

Il semble que sous certaines config une simple mise à jour du système résolve le problème, pour tester, juste après l'installation d'ubuntu, lancez simplement les commandes :

sudo apt-get update
sudo apt-get dist-upgrade

Modifier ensuite les options:
Les options qui fonctionnent le plus souvent sont le réglage d'antenne et l'interdiction de mise en veille de la carte, je vous propose de modifier l'option d'antenne et d'interdire la mise en veille.
Sur mon système c'est l'antenne 2 qui fonctionne le mieux, voici donc la démarche à suivre :

1- On modifie l'option d'antenne et on interdit la mise en veille en rendant les options persistantes (*) :

echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

2- On Redémarre le module (*) :

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

3- Si jamais ça ne fonctionne toujours pas (ou mal), on refais un essais en basculant sur l'antenne 1 (*) :

echo "options rtl8723be fwlps=0 ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723be.conf
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

2eme solution proposé : le script maison de metalux :

Metalux utilise ce script systemd sur son Pc car de temps en temps la connexion ne se fait pas toujours en sortie de veille.

sudo nano /etc/systemd/system/wifi-resume.service

coller ensuite dans le terminal ceci:

[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Faire ctrl+X puis O et enfin la touche "entrée" pour sauvegarder
Pour démarrer le service et qu'il se lance au démarrage:

sudo systemctl start wifi-resume.service
sudo systemctl enable wifi-resume.service

Si le script ne fonctionne pas, vous pouvez essayez la version du script suivante :

[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/sbin/rmmod rtl8723be 
/sbin/modprobe rtl8723be

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Faire ctrl+X puis O et enfin la touche "entrée" pour sauvegarder
Pour démarrer le service et qu'il se lance au démarrage:

sudo systemctl start wifi-resume.service
sudo systemctl enable wifi-resume.service

Et puis en ce qui concerne les options je vous donne rendez vous en fin de tuto pour donner la marche à suivre, car elle est identique qu'elle que soit la solution pour laquelle vous avez opté.

3eme solution proposé : Compiler le module git :

Ce tuto devrait également fonctionner pour les cartes wifi suivantes: rtl8188ee rtl8192c rtl8192ce rtl8192cu rtl8192de rtl8192ee rtl8192se rtl8723ae rtl8723com rtl8821ae et rtl8723be bien entendu.
Bien sûr lors des commandes renvoyant à la carte rtl8723be, vous devrez remplacer par la référence de votre carte.

Vérifions tout d'abord que votre carte soit bien une de celles cités dans la liste :

lspci | grep "Network"

Si c'est bien le cas, passons à la solution.

1- On installe :

sudo apt-get install git
sudo apt-get install linux-headers-generic build-essential dkms git

2- On télécharge les modules puis on se place dans le répertoire :

git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new

3- On compile puis on installe les modules compilés :

make all
sudo make install

4- On recharge le module (*) :

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

A ce stade nous avons installé le module, reste à le paramétrer avec les bonnes options.
Je vous donne rendez vous en fin de tuto pour donner la marche à suivre, car elle est identique qu'elle que soit la solution pour laquelle vous avez opté.

4eme solution proposé : le PPA

Cette solution est à utiliser en dernier recours, car selon Pilot6, le dev du ppa, information relayé par xubu1957 :

xubu1957 a écrit :

Je maintiens le hanipouspilotPPA. C'est pourquoi je peux donner la meilleure réponse ;-)
Je n'ai pas téléchargé un rtlwifi-new-dkmspaquet pour Yakkety 16.10.
Vous pouvez essayer de télécharger le deb pour Xenial, mais il est peu probable qu'il soit construit pour le noyau 4.8. Je ne l'ai pas testé.
La raison est simple. Je n'utilise pas cette version et je ne peux pas tester le module.
Vous pouvez essayer d'utiliser un pilote à partir de https://github.com/lwfinger/rtlwifi_new

Cependant, si rien n'a fonctionné sous votre config, ça ne coute rien d'essayer ... Avec les commandes suivantes :

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install  rtlwifi-new-dkms

Et puis en ce qui concerne les options je vous donne rendez vous en fin de tuto pour donner la marche à suivre, car elle est identique qu'elle que soit la solution pour laquelle vous avez opté.

Les options !

Il existe plusieurs options pour cette carte, pour les connaitre, entrez la commande :

modinfo -p rtl8723be

Le prompt devrait vous retourner :

swenc:Set to 1 for software crypto (default 0)
 (bool)
ips:Set to 0 to not use link power save (default 1)
 (bool)
swlps:Set to 1 to use SW control power save (default 0)
 (bool)
fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
debug:Set debug level (0-5) (default 0) (int)
disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)

Les options qui fonctionnent le plus souvent sont le réglage d'antenne et l'interdiction de mise en veille de la carte, je vous propose de modifier l'option d'antenne et d'interdire la mise en veille.
Sur mon système c'est l'antenne 2 qui fonctionne le mieux, voici donc la démarche à suivre :

1- On modifie l'option d'antenne et on interdit la mise en veille en rendant les options persistantes (*) :

echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

2- On Redémarre le module (*) :

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

3- Si jamais ça ne fonctionne toujours pas (ou mal), on refais un essais en basculant sur l'antenne 1 (*) :

echo "options rtl8723be fwlps=0 ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723be.conf
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Si vous avez opté pour la solution qui convient à votre config, vous devriez remarquer avec ses options un changement radical de votre connexion wifi (tout d'un coup ça fonctionne !!), cependant, si il reste quelques problèmes, metalux donne quelques pistes quand aux options que vous pouvez essayer chez vous :

metalux a écrit :

Déconnexions régulières au bout d'un certains temps aléatoire :   fwlps=0
Signal faible: changer l'antenne: ant_sel=1 ou ant_sel=2
Fichiers de log qui grossissent à vu d'oeil après avoir obtenu le wifi : msi=1
Il y a aussi les options ips=0 et swlps=0 qui sont parfois utilisées mais je ne me rappelle plus leur utilité. si vous avez des précisions à apporter...
Pour connaître ses réglages:
for f in /sys/module/rtl8723be/parameters/*; do echo -n "$f: " ; cat "$f" ; done

J'ai volontairement évité de surcharger avec les test d'antenne possibles avant de rendre l'option persistante puisque de toute façon la commande proposé écrase toutes les options préalablement paramétrés.
Si jamais vous voulez supprimer toutes les options et les remettre par défaut, voici la commande à envoyer :

rm  /etc/modprobe.d/rtl8723be.conf
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Notes :
(*) C'est là que si votre carte est dans la liste que j'ai donné mais n'est pas la rtl8723be il faudra modifier la commande avec la référence de votre propre carte.

AJOUT

Un dernier problème réccurent avec cette carte (c'est mon cas) :
Je vous conseille de vérifier votre journal de log au boot :

dmesg

Si le journal renvoyé par le prompt est saturé par des erreurs du style :

[  210.610457] pcieport 0000:00:1c.5: AER: Multiple Corrected error received: id=00e5
[  210.610812] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
[  210.610820] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
[  210.610826] pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
[  210.610830] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
[  210.611176] pcieport 0000:00:1c.5: can't find device of ID00e5
[  210.611178] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
[  210.611183] pcieport 0000:00:1c.5: can't find device of ID00e5
[  210.611196] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5

Pour régler ce problème, il suffit selon le launchpad de rentrer les commandes suivantes :
1) éditer :

nano /etc/default/grub

2) remplacer la ligne commençant par GRUB_CMDLINE_LINUX_DEFAULT par la ligne suivante :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

3) update du grub :

sudo update-grub

4) reboot

Merci aux diverses personnes impliqués qui donnent des infos relatives à cette carte depuis plusieurs mois sur les forum Ubuntu, deepin-fr et sur le blog d'Angristan. Si il y a des inexactitudes dans le tuto n'hésitez pas de me le faire remarquer en commentaire, je ne manquerais pas d'éditer.
En espérant avoir pu vous être utile.
Cordialement, lobo.

Dernière modification par lobo1512 (Le 30/12/2017, à 13:09)


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#2 Le 26/12/2017, à 13:24

xubu1957

Re : [TUTO] Module carte wifi realtek rtl8723be

Bonjour,

metalux avait proposé une option supplémentaire :

Le 30/12/2016, metalux a écrit :

J’utilise ce script systemd sur mon Pc car de temps en temps la connexion ne se fait pas toujours en sortie de veille.

sudo nano /etc/systemd/system/wifi-resume.service

coller ensuite dans le terminal ceci:

[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Faire ctrl+X puis O et enfin la touche "entrée" pour sauvegarder
Pour démarrer le service et qu'il se lance au démarrage:

sudo systemctl start wifi-resume.service
sudo systemctl enable wifi-resume.service

Pour que le réglage de l'antenne soit permanent:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Si tu as des déconnexions, ajoute également l'option fwlps=0, dans ce cas entre cette commande:

echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

> [Résolu]Wifi rtl8723be ne fonctionne pas

Dernière modification par xubu1957 (Le 26/12/2017, à 13:25)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 26/12/2017, à 13:54

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

xubu1957 a écrit :

Bonjour,

metalux avait proposé une option supplémentaire :

Le 30/12/2016, metalux a écrit :

J’utilise ce script systemd sur mon Pc car de temps en temps la connexion ne se fait pas toujours en sortie de veille.

sudo nano /etc/systemd/system/wifi-resume.service

coller ensuite dans le terminal ceci:

[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Faire ctrl+X puis O et enfin la touche "entrée" pour sauvegarder
Pour démarrer le service et qu'il se lance au démarrage:

sudo systemctl start wifi-resume.service
sudo systemctl enable wifi-resume.service

Pour que le réglage de l'antenne soit permanent:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Si tu as des déconnexions, ajoute également l'option fwlps=0, dans ce cas entre cette commande:

echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

> [Résolu]Wifi rtl8723be ne fonctionne pas

Merci Xubu, je n'avais pas vu cette solution, et du coup je ne l'ai pas testé. Par contre je pense que l'option fwlps=0 ne dois plus fonctionner aujourd'hui, je l'ai testé hier avec le module par défaut et avec le module compilé, dans les 2 cas le prompt me renvois une erreur d'argument invalide qui empêche de le recharger. Du coup je pense que cette option a été supprimé car mise par défaut dans les nouvelles versions des modules. Par contre il est possible que sur le ppa l'option soit toujours présente car il me semble qu'il n'est plus mis à jour depuis un moment.

A la lecture du code proposé par Metalux je comprend qu'il modifie le comportement de la carte, je ne suis pas certain que ça soit pertinent aujourd'hui car depuis le module installé par défaut s'est nettement amélioré et fonctionne beaucoup mieux (par exemple en ce qui concerne les problèmes de mise en veille, du coup les restart ne me paraissent plus utiles, mais c'est à vérifier). Cependant, s'il fonctionne mieux il reste un problème de porté et de débit largement inférieur au module du dépôt git.

Merci pour l'info supplémentaire, tu es vraiment toujours présent et super réactif ! smile

Dernière modification par lobo1512 (Le 26/12/2017, à 13:55)


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#4 Le 26/12/2017, à 14:01

metalux

Re : [TUTO] Module carte wifi realtek rtl8723be

Bonjour,
Pour avoir installé plusieurs variantes d'ubuntu 16.04, Xubuntu et Ubuntu-mate principalement sur plusieurs pc avec cette carte, je peux affirmer que j'ai toujours obtenu un résultat correct mais que la solution n'est pas universelle. Le mieux est de procéder par élimination en fonction des symptômes.
Je rappelles que pour avoir la liste des options, il faut passer par cette commande:

modinfo -p rtl8723be

Un point à vérifier que j'ai rencontré sur 2 Pcs et qui peut avoir des conséquences secondaires est la taille des fichiers logs:
https://forum.ubuntu-fr.org/viewtopic.p … #p21573542

Pour résumer, je dirais:
Pas du tout de wifi: voir le PPA ou la compilation du module
Pas de connexion en sortie de veille: Utiliser un script systemd
Déconnexions régulières au bout d'un certains temps aléatoire :   fwlps=0
Signal faible: changer l'antenne: ant_sel=1 ou ant_sel=2
Fichiers de log qui grossissent à vu d'oeil après avoir obtenu le wifi : msi=1
Il y a aussi les options ips=0 et swlps=0 qui sont parfois utilisées mais je ne me rappelle plus leur utilité. si vous avez des précisions à apporter...
Edit:
Pour connaître ses réglages:

for f in /sys/module/rtl8723be/parameters/*; do echo -n "$f: " ; cat "$f" ; done

@lobo1512

Par contre je pense que l'option fwlps=0 ne dois plus fonctionner aujourd'hui

Je teste sans et je repasse le dire un peu plus tard, là je n'ai pas le temps.

A la lecture du code proposé par Metalux je comprend qu'il modifie le comportement de la carte, je ne suis pas certain que ça soit pertinent aujourd'hui car depuis le module installé par défaut s'est nettement amélioré et fonctionne beaucoup mieux (par exemple en ce qui concerne les problèmes de mise en veille, du coup les restart ne me paraissent plus utiles, mais c'est à vérifier)

Idem, je vais désactiver le script systemd que j'utilise et je vois ce qu'il en est. je confirmerai le résultat.

Cependant, s'il fonctionne mieux il reste un problème de porté et de débit largement inférieur au module du dépôt git.

Non, pas dans mon cas. Sur le Pc de ma fille, oui, il y a une différence avec le module du dépôt git et ant_sel=2 comme quoi, chaque cas est bien particulier en fonction de chaque Pc.

Dernière modification par metalux (Le 26/12/2017, à 14:09)

Hors ligne

#5 Le 26/12/2017, à 14:08

xubu1957

Re : [TUTO] Module carte wifi realtek rtl8723be

J'avais fourni l'info pour le PPA :

Le 08/11/2017, xubu a écrit :

@ Naziel

Le 26/11/2016- traduction, Pilot6 a écrit :

Je maintiens le hanipouspilotPPA. C'est pourquoi je peux donner la meilleure réponse ;-)

Je n'ai pas téléchargé un rtlwifi-new-dkmspaquet pour Yakkety 16.10.

Vous pouvez essayer de télécharger le deb pour Xenial, mais il est peu probable qu'il soit construit pour le noyau 4.8. Je ne l'ai pas testé.

La raison est simple. Je n'utilise pas cette version et je ne peux pas tester le module.

Vous pouvez essayer d'utiliser un pilote à partir de https://github.com/lwfinger/rtlwifi_new

dans realtek-rtl8723be-wifi-card-in-ubuntu-16-10

> [résolu] installation wiifi carte realtek . RTL8723BE

Pour optimiser ces conseils pratiques > Wi-Fi-connexion-amelioration

Tu n'as pas du dual-band ? > 2.4-ghz-et-5-ghz-quel-wifi-choisir

et aussi ce fil : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot et cette réponse :

jdt37b a écrit :

xubu1957,
Pour info, dans un environnement encombré (bluetooth, téléphone DECT, murs, parties métalliques, autres réseaux wifi, ...) et à 6m de distance d'une box à 8000 kbps maxi, après moult tests et plusieurs semaines d'utilisation :
Ce qui a fait nettement la différence pour obtenir une connexion correcte en temps et en débit, c'est de baisser le tx-power et le bitrate de la carte Wifi comme ça :
Dans le fichier  /etc/rc.local :

ifconfig wls1 up
iwconfig wls1 txpower 5mW
iwconfig wls1 rate 11.0M auto

Si ça peut être utile !

Doc : wifi_optimisation#regler_les_parametres_reseaux

Solution appliquée avec un pilote RealtekRésolu] Déconnections wifi carte realtek8821ae

>[script/bash] wifi et sante. Changer la puissance du signal.

autre script >[Wifi] Optimiser la portée et/ou le débit et/ou la consommation


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#6 Le 26/12/2017, à 14:10

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

lobo@lobo-pc:~$ modinfo -p rtl8723be
swenc:Set to 1 for software crypto (default 0)
 (bool)
ips:Set to 0 to not use link power save (default 1)
 (bool)
swlps:Set to 1 to use SW control power save (default 0)
 (bool)
fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
debug:Set debug level (0-5) (default 0) (int)
disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)
lobo@lobo-pc:~$ echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
[sudo] Mot de passe de root : 
options rtl8723be fwlps=0 ant_sel=2
lobo@lobo-pc:~$ sudo modprobe -r rtl8723be
lobo@lobo-pc:~$ sudo modprobe rtl8723be

Du coup vous avez raison, je ne sais pas pourquoi hier j'ai eu les retours d'arguments invalides -elle est vraiment capricieuse cette carte !!- J'édite le tuto.


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#7 Le 26/12/2017, à 14:14

metalux

Re : [TUTO] Module carte wifi realtek rtl8723be

Petite précision concernant mon post précédent, toutes les installations que j'ai faîtes sont sur des 16.04 et sur au moins 4 configurations différentes, voire plus.
Pour information, tout fonctionne "out-of-the-box" avec manjaro, toutes les distribs basées sur Debian et Ubuntu sont quant à elles touchées.

Hors ligne

#8 Le 26/12/2017, à 14:20

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

J'ai une urgence à la maison, je vous relis et j'édite ensuite dans l'aprem ou ce soir.
A +


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#9 Le 26/12/2017, à 18:38

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

Je m'excuse par avance pour le double post, c'est pour que xubu et metalux (et tous-tes celleux qui le désirent) puissent remarquer que le tuto a été édité et que je puisse avoir connaissance de leurs avis afin de savoir s'il est encore incomplet ou s'il y a des trucs à modifier.


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#10 Le 26/12/2017, à 18:56

xubu1957

Re : [TUTO] Module carte wifi realtek rtl8723be

Le PPA hanipouspilot/rtlwifi ne va pas au delà de la version 16.04.1 LTS et la série de noyaux 4.4, il pourra servir jusqu'en avril 2021.

Il serait intéressant que Naziel donne son avis, en tant qu'utilisateur et intervenant régulier pour ce pilote  !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#11 Le 27/12/2017, à 13:45

Naziel

Re : [TUTO] Module carte wifi realtek rtl8723be

Bonjour,

Effectivement, le PPA est à utiliser en dernier recours vu qu'il n'est valable que pour ubuntu 16.04.1 et les ubuntu 14.04.X (les versions 16.04.X ayant des noyaux pas adaptés pour le PPA car plus récents que ubuntu 16.10). De plus, il me semble que j'avais testé le PPA sur ubuntu 16.04.? et ça n'avait pas marché (je ne sais pas quelle version j'avais exactement à ce moment là mais ça devait pas être ?=1)

Quelques remarques sur le premier message:
- sudo apt-get upgrade n'est pas utile, car

man apt-get partie dist-upgrade a écrit :

           La commande dist-upgrade effectue la fonction upgrade en y ajoutant
           une gestion intelligente des changements de dépendances dans les
           nouvelles versions des paquets

- Dans la première solution, 4), je suis pas sûr que la commande

sudo modprobe rtl8723be

recharge le module.
Celle ci

sudo modprobe -r rtl8723be ; sudo modprobe rtl8723be

va d'abord décharger le pilote puis le recharger.

- Une autre info est l'absence d'installation de dkms dans https://github.com/lwfinger/rtlwifi_new . Je ne sais pas si dkms est utilisé, si ce n'est pas le cas, il faut réinstaller le pilote compilé à chaque changement de noyau.

Je n'ai pas le problème qui nécessite pci=noaer comme paramètre noyau, j'ai pourtant un pc avec une carte rtl8723be et j'ai accès à un autre pc sur ubuntu 14.04 (avec le PPA hanipouspilot/rtlwifi) qui a une carte rtl8723be aussi mais qui n'a pas non plus ces problèmes avec pci=noaer.

Dernière modification par Naziel (Le 27/12/2017, à 13:46)

Hors ligne

#12 Le 27/12/2017, à 16:47

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

Naziel a écrit :

Bonjour,

Effectivement, le PPA est à utiliser en dernier recours vu qu'il n'est valable que pour ubuntu 16.04.1 et les ubuntu 14.04.X (les versions 16.04.X ayant des noyaux pas adaptés pour le PPA car plus récents que ubuntu 16.10). De plus, il me semble que j'avais testé le PPA sur ubuntu 16.04.? et ça n'avait pas marché (je ne sais pas quelle version j'avais exactement à ce moment là mais ça devait pas être ?=1)

Oui, c'est ce qui me semblait aussi et Xubu avait relayé l'info, par ailleurs, le pc que j'ai avec cette carte était sous deepin avant, et de souvenir ça fonctionner avec la 15.4 et ça ne fonctionne plus avec la 15.5.

Naziel a écrit :

Quelques remarques sur le premier message:
- sudo apt-get upgrade n'est pas utile, car

man apt-get partie dist-upgrade a écrit :

           La commande dist-upgrade effectue la fonction upgrade en y ajoutant
           une gestion intelligente des changements de dépendances dans les
           nouvelles versions des paquets

Exact, le upgrade est inutile, j'ai édité cette partie.

Naziel a écrit :

- Dans la première solution, 4), je suis pas sûr que la commande

sudo modprobe rtl8723be

recharge le module.
Celle ci

sudo modprobe -r rtl8723be ; sudo modprobe rtl8723be

va d'abord décharger le pilote puis le recharger.

Un oublie de ma part, c'est corrigé.

Naziel a écrit :

- Une autre info est l'absence d'installation de dkms dans https://github.com/lwfinger/rtlwifi_new . Je ne sais pas si dkms est utilisé, si ce n'est pas le cas, il faut réinstaller le pilote compilé à chaque changement de noyau.

Il me semble qu'il faille le réinstaller, mais sans être certain, ce qui par contre est sur c'est que parfois il faille basculer d'antenne après up du noyau.

Naziel a écrit :

Je n'ai pas le problème qui nécessite pci=noaer comme paramètre noyau, j'ai pourtant un pc avec une carte rtl8723be et j'ai accès à un autre pc sur ubuntu 14.04 (avec le PPA hanipouspilot/rtlwifi) qui a une carte rtl8723be aussi mais qui n'a pas non plus ces problèmes avec pci=noaer.

Il semble que le problème apparait avec certains pc et d'autres non, je n'ai aucune idée du pourquoi ni du comment mais c'est le cas sur mon hp notebook 17-x010nf.

Merci de ta/vos réponses, si quelqu'un peut confirmer qu'il est nécessaire de recompiler puis installer à chaque changement de noyau j'éditerai pour rajouter l'info.


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#13 Le 28/12/2017, à 13:15

metalux

Re : [TUTO] Module carte wifi realtek rtl8723be

Comme promis, voici le retour d'expérience depuis 2 jours, tests réalisés sur 2 Pcs:

1-Le 1er PC se déconnectait régulièrement sans l'option fwlps=0 et refusait de se connecter en sortie de veille sans un script systemd qui redémarrait NetworkManager.
Suppression du script systemd et supression du fichier  /etc/modprobe.d/rtl8723be.conf pour un retour par défaut. Tout fonctionne désormais sur ce PC avec le module par défaut que ce soit avec le noyau 4.4 ou le 4.10 smile

2-Le second PC, une Ubuntu-mate 16.04 avait été installé à partir de cette méthode, en récupérant le Deb du P.P.A. à partir d'un live et en ajoutant les options suivantes:

msi=1 ant_sel=2

Suppression depuis 48 heures du paquet rtlwifi-new-dkms en provenance du P.P.A. avec un retour au module par défaut présent sur Ubuntu. Les options sont toujours nécessaires mais le réglage de l'antenne donne maintenant un résultat similaire avec l'antenne 1 ou 2 alors que seule la 2 fonctionnait au début avec le paquet du P.P.A. Le réglage de l'antenne bien que fonctionnant avec 1 ou 2 ne fonctionne pas en automatique ( 0 par défaut) et nécessite toujours la création du fichier /etc/modprobe.d/rtl8723be.conf. Le noyau utilisé est un 4.4 car c'est une 16.04.1 de base.

En conclusion, il y a eu de gros progrès de fait, le module par défaut remplit son rôle maintenant alors que ce n'était pas le cas dans le passé pour ces 2 Pcs. Au niveau des options, il y a également eu une avancé, fwlps=0 n'étant plus nécessaire pour le PC N°1. Le réglage de l'antenne reste malgré tout d'actualité sur le PC N°2.
A partir de ces éléments, je te propose lobo1512 d'inverser l'ordre des solutions proposées avec en premier l'update/upgrade, et en deuxième le réglage de l'antenne qui semble quand même un des cas le plus fréquent.
Dans la partie concernant la non connexion en sortie de veille avec un script systemd (est-il toujours d'actualité?) tu peux ajouter la solution concernant le remplacement de ExecStart=/bin/systemctl restart network-manager.service par ExecStart=/sbin/rmmod rtl8723be ; /sbin/modprobe rtl8723be si la 1ère ne fonctionnait pas ( cf https://forum.ubuntu-fr.org/viewtopic.p … #p21664769 )

Hors ligne

#14 Le 30/12/2017, à 13:26

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

metalux a écrit :

Comme promis, voici le retour d'expérience depuis 2 jours, tests réalisés sur 2 Pcs:

1-Le 1er PC se déconnectait régulièrement sans l'option fwlps=0 et refusait de se connecter en sortie de veille sans un script systemd qui redémarrait NetworkManager.
Suppression du script systemd et supression du fichier  /etc/modprobe.d/rtl8723be.conf pour un retour par défaut. Tout fonctionne désormais sur ce PC avec le module par défaut que ce soit avec le noyau 4.4 ou le 4.10 smile

2-Le second PC, une Ubuntu-mate 16.04 avait été installé à partir de cette méthode, en récupérant le Deb du P.P.A. à partir d'un live et en ajoutant les options suivantes:

msi=1 ant_sel=2

Suppression depuis 48 heures du paquet rtlwifi-new-dkms en provenance du P.P.A. avec un retour au module par défaut présent sur Ubuntu. Les options sont toujours nécessaires mais le réglage de l'antenne donne maintenant un résultat similaire avec l'antenne 1 ou 2 alors que seule la 2 fonctionnait au début avec le paquet du P.P.A. Le réglage de l'antenne bien que fonctionnant avec 1 ou 2 ne fonctionne pas en automatique ( 0 par défaut) et nécessite toujours la création du fichier /etc/modprobe.d/rtl8723be.conf. Le noyau utilisé est un 4.4 car c'est une 16.04.1 de base.

En conclusion, il y a eu de gros progrès de fait, le module par défaut remplit son rôle maintenant alors que ce n'était pas le cas dans le passé pour ces 2 Pcs. Au niveau des options, il y a également eu une avancé, fwlps=0 n'étant plus nécessaire pour le PC N°1. Le réglage de l'antenne reste malgré tout d'actualité sur le PC N°2.
A partir de ces éléments, je te propose lobo1512 d'inverser l'ordre des solutions proposées avec en premier l'update/upgrade, et en deuxième le réglage de l'antenne qui semble quand même un des cas le plus fréquent.
Dans la partie concernant la non connexion en sortie de veille avec un script systemd (est-il toujours d'actualité?) tu peux ajouter la solution concernant le remplacement de ExecStart=/bin/systemctl restart network-manager.service par ExecStart=/sbin/rmmod rtl8723be ; /sbin/modprobe rtl8723be si la 1ère ne fonctionnait pas ( cf https://forum.ubuntu-fr.org/viewtopic.p … #p21664769 )

Je viens d'éditer (désolé hier je n'ai pas pu). Petite précision : je viens de tester sous Kali-linux, en ce qui concerne le wifi la carte fonctionne parfaitement avec le module de base simplement avec une option d'antenne. En mode monitor également, j'ai essayé de faire un scan avec Fern et je trouve tous les wifi de mon immeuble, et même les box des restaurants qui sont à 200 mêtres ! Connexion super stable et un très bon débit.
- Je précise quand même que j'ai fait ça UNIQUEMENT pour tester la carte et le module, en simulant une attaque mais sans la lancer, "hacker" le wifi de la voisine c'est pas mon truc, j'ai passé l'âge... -
Bref, par contre sous Kali il y a un problème avec le bluetoot avec le module de base.
Conclusion : je pense que cette carte peut donner de très bons résultats sous n'importe quelle distri une fois que l'on trouve la bonne config, et c'est pas toujours évident.


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#15 Le 30/12/2017, à 14:04

Naziel

Re : [TUTO] Module carte wifi realtek rtl8723be

@lobo1512: c'est vrai qu'elle marche bien en monitoring.  Pour le bluetooth, j'ai jamais réussi à le faire fonctionner sous linux, et le peu qu'il ait fonctionné sous windows engendrait des pertes de vitesse en wifi. Oui, le wifi fonctionne au poil avec les bons paramètres!

Hors ligne

#16 Le 30/12/2017, à 15:47

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

Naziel a écrit :

@lobo1512: c'est vrai qu'elle marche bien en monitoring.

C'est clair ! En fait elle fonctionne tellement mieux sous kali (même en mode normal) que sur ce pc j'ai fais de kali ma distri principale en ajoutant les dépôts debian contrib et nonfree et en créant un compte user non root avec des droits sudo (qui exige quand même le mdp root) pour pas faire n'importe quoi lorsque je suis en mode détente.

Je me pose quand même la question de pourquoi il y a une telle différence de résultat entre kali et toutes les autres distri que j'ai testé avec cette carte ?


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#17 Le 30/12/2017, à 16:06

Naziel

Re : [TUTO] Module carte wifi realtek rtl8723be

Peut être une différence de noyau: le code pour cette carte wifi est inclus dans le noyau, tu as peut être un noyau plus récent (je sais pas comment ça marche chez kali pour les noyaux ni quelle version tu as)

Hors ligne

#18 Le 30/12/2017, à 17:48

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

Naziel a écrit :

Peut être une différence de noyau: le code pour cette carte wifi est inclus dans le noyau, tu as peut être un noyau plus récent (je sais pas comment ça marche chez kali pour les noyaux ni quelle version tu as)

Si ça peut t'aider à y voir plus clair :

lobo@kali-01:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Kali
Description:	Kali GNU/Linux Rolling
Release:	kali-rolling
Codename:	kali-rolling
lobo@kali-01:~$ cat /proc/version
Linux version 4.14.0-kali1-amd64 (devel@kali.org) (gcc version 7.2.0 (Debian 7.2.0-16)) #1 SMP Debian 4.14.2-1kali1 (2017-12-04)

EDIT: Oui, noyau plus récent, ça doit être ça qui fait la différence. Peut-être que lors de la sortie de la 18.04Lts Ubuntu (je sais pas quel noyau est prévu) on aura les mêmes résultats.

EDIT2: Par contre en ce qui concerne les erreurs pci le mode "noaer" dans le grub est toujours nécessaire sur ma config.

Dernière modification par lobo1512 (Le 30/12/2017, à 17:58)


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#19 Le 30/12/2017, à 18:01

Naziel

Re : [TUTO] Module carte wifi realtek rtl8723be

Effectivement, il est sacrément récent ce noyau!!!
Pour te montrer à quel point il est récent, la version stable existante la plus récente est 4.14.10 ( https://www.kernel.org/ ) , et d'après https://wiki.ubuntu.com/Kernel/LTSEnabl … el_Support , il faut attendre ubuntu 16.04.5 ou 18.04.0 pour avoir une version plus récente que la tienne.

Cela dit, j'ai compilé et installé le noyau 4.14.6 sur xubuntu et j'ai pas non plus besoin de ppa ni du dépôt git, je change juste d'antenne (c'était pas pour ça que j'ai changé le noyau, c'était juste pour le fun)

Edit: oui, je pense qu'il restera à modifier les options du module sur la 18.04

Edit 2: je sais pas ce que signifie ce paramètre, ni son intérêt...

Dernière modification par Naziel (Le 30/12/2017, à 18:05)

Hors ligne

#20 Le 30/12/2017, à 18:20

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

Naziel a écrit :

Cela dit, j'ai compilé et installé le noyau 4.14.6 sur xubuntu et j'ai pas non plus besoin de ppa ni du dépôt git, je change juste d'antenne (c'était pas pour ça que j'ai changé le noyau, c'était juste pour le fun)

Tu n'as aucun problème d'instabilité ?

-ça me donne envie de tester en VM, tu penses que c'est possible avec 2go de ram alloué à la VM ? (je commence à peine à découvrir la virtualisation et les test d'intrusion en labo avec les outils de kali, en parallèle à l'apprentissage du python) -

Naziel a écrit :

Edit 2: je sais pas ce que signifie ce paramètre, ni son intérêt...

En fait il me semble que l'erreur est toujours présente et que tout ce que fait ce paramètre c'est de la faire disparaître du journal de log, du coup ça règle pas vraiment le problème mais ça évite de devoir attendre 5 minutes au boot avec une erreur récurrente qui se répète à l'infini avant de lancer le gestionnaire de session.
Mais malgré mes recherches je n'ai pas trouvé de meilleure solution et c'est tout ce que propose le launchpad.


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#21 Le 30/12/2017, à 19:05

Naziel

Re : [TUTO] Module carte wifi realtek rtl8723be

Non, aucun problème d'instabilité, il y a juste la carte graphique que j'arrive pas à faire marcher et qui marche pourtant d'habitude avec le pilote libre radeon (mais vu que je joue pas à minecraft en ce moment et que j'ai un noyau de secours, il y a pas de problème). Par contre, le compiler c'est bien, en faire un paquet à installer c'est mieux (et ça j'ai pas fait, du coup je sais pas trop comment le désinstaller...).

ça me donne envie de tester en VM, tu penses que c'est possible avec 2go de ram alloué à la VM ?

Aucune idée, c'est pas la compilation qui prendra le plus de mémoire vive je pense, c'est le système. Tu as combien de RAM? Perso je mettrai 4 Go pour être tranquille.
Et pense à régler le swapiness avant sur le système hôte, sinon tu auras une mauvaise surprise.

Ok pour le paramètre.

[HS]Vu que tu t'intéresses à la sécurité informatique, il y a https://doc.ubuntu-fr.org/rtl-sdr qui est sympa à essayer (le matériel coûte une vingtaine d'euros et c'est super amusant)
Et c'est une formation que tu suis ou c'est des tutos sur internet? Si c'est le deuxième cas, je veux bien quelques sources[/HS]

Hors ligne

#22 Le 30/12/2017, à 19:41

lobo1512

Re : [TUTO] Module carte wifi realtek rtl8723be

Naziel a écrit :

Perso je mettrai 4 Go pour être tranquille.
Et pense à régler le swapiness avant sur le système hôte, sinon tu auras une mauvaise surprise.

Oui, 4go ça serait bien, c'est ce que je pensais aussi, le truc c'est que j'ai juste 4go sur mon pc (c'est très con car j'ai un processseur I7 4core dessus et que du coup je peux pas l'exploiter, mais c'est toujours le problème lorsque tu profite d'une offre -75%... Et pour l'instant j'ai pas les moyens de racheter de la ram, dès que je peux j'y colle 32go)
Merci du conseil pour le swap.

[HS]Vu que tu t'intéresses à la sécurité informatique, il y a https://doc.ubuntu-fr.org/rtl-sdr qui est sympa à essayer (le matériel coûte une vingtaine d'euros et c'est super amusant)
Et c'est une formation que tu suis ou c'est des tutos sur internet? Si c'est le deuxième cas, je veux bien quelques sources[/HS]

Yes! ça m'intérresse oui !!! Dans la même idée j'avais aussi fait des recherches concernant le brouillage des basses et hautes fréquences (GSM et les BF des talki walki) mais j'ai rien trouvé de probant.
Sinon pour le moment en ce qui concerne l'apprentissage je suis le cours python d'openclassroom et un livre pdf de Gérard Swinnem que je veux bien t'envoyer par mail si tu veux.
Pour la formation dev python, j'ai demandé un financement à la région (bretagne) et à pôle emplois, les 2 ont refusé.

Dernière modification par lobo1512 (Le 30/12/2017, à 20:37)


Ubuntu 16.04 ; Deepin 15.4.1 ; Ubuntu server ; Debian server ; Kali-Linux

Hors ligne

#23 Le 30/12/2017, à 19:59

Naziel

Re : [TUTO] Module carte wifi realtek rtl8723be

Ah, 32 Go carrément! (j'en ai 8 mais c'est vrai que les machines virtuelles ça en bouffe de la RAM)
Par contre, je te conseillerais d'éditer ton précédent message pour enlever ton email et activer dans ton profil du forum le fait de pouvoir t'envoyer un message privé. Sinon tu risques de te faire spammer.
Si tu veux, je te donnerai aussi quelques sources aussi.

Hors ligne

#24 Le 11/08/2018, à 09:10

pipa

Re : [TUTO] Module carte wifi realtek rtl8723be

merci
a tous  tous
ça marche nickel j'ai carrément les 4 barres sur applet wi fi
pour moi : options rtl8723be fwlps=0 ant_sel=1
est mieux que la sel 2
bonne journée

Dernière modification par pipa (Le 11/08/2018, à 09:32)

Hors ligne

#25 Le 11/08/2018, à 09:25

NicoApi73

Re : [TUTO] Module carte wifi realtek rtl8723be

Bonjour pipa,
Vérifie avec dmesg -lerr que tu n'aies pas de message d'erreur de type pcieport

Hors ligne